Announcement

Announcement Module
Collapse
No announcement yet.

Game Booster won't work

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Game Booster won't work

    I was using game booster 3 just fine before, now Im having problems with it, I cant explain what the problem is, just take a look at it:
    http://prntscr.com/gmj27

    clicking gamebox does nothing.
    I've tried re-downloading game box 3, it just leads me to razor booster sign up page.

  • #2
    Welcome

    Welcome to the forum :smile:

    You can download Iobit Game Booster 3.4 (0504) Final @ MajorGeeks

    You can download IObit Game Booster version 3.5 Beta from the link in the thread IObit Game Booster 3.5 Beta is available! (Updated)
    Many members have said the Beta version is stable and an improvement on 3.4

    If you want to do a Clean Uninstall & Install
    See This Post for details.
    Screenshots are in This Post

    All the best, woz of oz
    FORUM USAGE GUIDELINES - Read this first
    Description of IObit Forum features and requirements - Reading this is compulsory
    The thread also includes Handy Links

    NEW USER PUBLIC PROFILE POLICY effective on February 01, 2013 !
    It is compulsory to add your OS + Computer Details to your Profile

    Usage of IObit Products
    Information about using IObit software
    Also contains a wealth of diverse information on many different related subjects

    Comment


    • #3
      Hi MattKimura, welcome to IObit Forum! :-D

      Try IObit Game Booster 3.5 Beta is available! (Updated) and IObit Game Booster 3.4 is available! (Updated May 04, 2012) threads to download Game Booster 3 for 2 different versions respectively.

      BTW, IObit and Razer have combined forces for Razer Game Booster of which closed beta testing is carried out at the moment.

      Cheers.
      enoskype

      - Beauty lies in the eye of the beholder and belongs to the man who can appreciate it. -

      Comment


      • #4
        Thanks guys, just the answer I needed. Glad to join a forum with nice users.

        One more thing on this topic, is it worth using game booster, even if my games run completely fine without game booster? There's no loss in using it huh

        Comment


        • #5
          Originally posted by MattKimura View Post
          Thanks guys, just the answer I needed. Glad to join a forum with nice users.

          One more thing on this topic, is it worth using game booster, even if my games run completely fine without game booster? There's no loss in using it huh
          If you see absolutely no improvement in your gaming experience on a particular game then it doesn't matter if you run it or not. It will help on heavier games if you ever see lags... etc.:wink:

          Sincerely,
          -Mel
          Live long and prosper!


          Comment


          • #6
            Originally posted by MattKimura View Post
            Thanks guys, just the answer I needed. Glad to join a forum with nice users.

            One more thing on this topic, is it worth using game booster, even if my games run completely fine without game booster? There's no loss in using it huh
            My theory on gaming is the less FPS reducing resources the better. I think it's hard to argue otherwise. I also think shutting down unnecessary resources reduce the chances of gaming conflicts. If you don't need a resource/process for a specific game, shut it down. This is why I think it is always better to run Game Booster. I have a fairly fast gaming rig and I still use it.
            Last edited by masterblaster; Oct. 3rd, 2012, 20:14.
            http://steamcommunity.com/id/MasterBlaster73

            Comment


            • #7
              I'm back again with the same problem, with beta 3.5
              This time the the interface isn't screwed up. I can't click on anything, I can't see the list of games, instead I see the options page. clicking on game box does nothing. It was working fine before.

              http://prntscr.com/h0pzj

              Un installing and installing fixes it for a while til it happens again.
              closing it and opening it again doesn't solve the problem.

              Comment


              • #8
                Originally posted by MattKimura View Post
                I'm back again with the same problem, with beta 3.5
                This time the the interface isn't screwed up. I can't click on anything, I can't see the list of games, instead I see the options page. clicking on game box does nothing. It was working fine before.

                http://prntscr.com/h0pzj

                Un installing and installing fixes it for a while til it happens again.
                closing it and opening it again doesn't solve the problem.
                You have the links for the newest versions of 3.4 and 3.5. Were the reinstalls clean ones? To make sure the install is a clean one, please review the links at the end of Wozofoz's post earlier in this thread. Of particular note is the deletion of the empty program file.

                Quote form Wozofoz's post:
                If you want to do a Clean Uninstall & Install
                See This Post for details.
                Screenshots are in This Post
                Sincerely,
                -Mel
                Live long and prosper!
                Last edited by Melvin_Deal; Oct. 9th, 2012, 02:41.


                Comment


                • #9
                  Thanks so much for the reply, I appreciate it.
                  I clean uninstalled/installed Game Booster 3.5
                  It's working fine now. I think the suspect is my portable Advanced System Care and the defrag program from Iobit. My game booster problem only happens after I use those two. After using those 2, they startup on with windows

                  Comment


                  • #10
                    Edit: My original reply below was based on having seen a few 'hacks' advertised on the internet in the past but you are probably referring to the portable version that can be created by Advanced SystemCare.
                    Sorry about that
                    Originally posted by MattKimura View Post
                    ..I think the suspect is my portable Advanced System Care and the defrag program from Iobit. My game booster problem only happens after I use those two. After using those 2, they startup on with windows
                    "portable Advanced SystemCare" ?
                    There is no official portable version of Advanced SystemCare that I know of.
                    If it is an unofficial hack of Advanced SystemCare then it could cause problems.

                    There is an official portable version of IObit Smart Defrag at PortableApps.com but I haven't tried it.
                    I don't know if it has the option to start with Windows but it should only start with Windows if that is what you selected

                    All the best, woz of oz
                    Last edited by wozofoz; Oct. 9th, 2012, 21:03. Reason: Edit:
                    FORUM USAGE GUIDELINES - Read this first
                    Description of IObit Forum features and requirements - Reading this is compulsory
                    The thread also includes Handy Links

                    NEW USER PUBLIC PROFILE POLICY effective on February 01, 2013 !
                    It is compulsory to add your OS + Computer Details to your Profile

                    Usage of IObit Products
                    Information about using IObit software
                    Also contains a wealth of diverse information on many different related subjects

                    Comment

                    Working...
                    X