Announcement

Collapse
No announcement yet.

Disable Superfetch & Prefetch while gaming?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disable Superfetch & Prefetch while gaming?

    Is this a good idea? If so, can we see it implemented into Razer Game Booster? Thanks!


    Disable SuperFetch and Prefetch.

    Both SuperFetch and Prefetch boost Windows and application start-up times (in some cases, at least!). For games, however, I noticed that loading times and background activity actually increases when both of these Windows caching features are enabled, so I recommend turning them both off if you’re an avid gamer.

    To do this, go to “Control Panel”, “System and Security”, “Administrative Tools” and “Services”. Scroll down until you see the “SuperFetch” entry, double-click on it, and choose “Disabled” from the list.







    Hit “OK”, and close all of the windows. Next, open up the registry; click on the Start orb, and type in “regedit”. Hit Enter, and go to “HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters”. Double-click on “EnablePrefetcher”, and enter “0” (default value is “3”) to disable the Prefetcher.

  • #2
    I've faced this issue before while gaming so I would suggest to disable it. This is caused by 100% CPU usage so to solve service host superfetch error, you've to disable superfetch and you can do this by following the steps below. For detailed guide check: https://clouttechie.com/solved-servi...e-usage-error/ One of the following steps will sort out the problem: 1.Disable from services - Run command services.msc and then disable superfetch. 2.Disable from Registry using Regedit command.

    Comment

    Working...
    X