Announcement

Announcement Module
Collapse
No announcement yet.

Advanced Mobile or System Care for tablets??

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Advanced Mobile or System Care for tablets??

    Hi there, sorry if this has been discussed somewhere else, but after some rooting around on here I can't seem to find a relevant thread. Anyway...
    I have a question for the PTB, which product(s) do you guys recommend to use with a Samsung Galaxy Tab 2 (7" version) and also a Kindle Fire HD?
    I have the kindle and the MIL has the tab 2 and we can't install the mobile app from either the Play Store, the Samsung App Store or the Amazon App store.
    We both have Galaxy s3 mobiles and use the mobile app on those, (and have ASC 6 pro on our laptops/desktops) but when I try to install onto the Tab 2 from Google play it says "version not compatible with your device" and as my kindle' s not rooted I can't download from Google either (and there's no iobit apps in the Amazon store)
    Any help or suggestions would be appreciated, feel kind of naked having a device without ASC / AMC installed:shock:

  • #2
    Welcome

    Welcome to the forum :smile:
    Originally posted by TheCatsMother View Post
    but when I try to install onto the Tab 2 from Google play it says "version not compatible with your device" and as my kindle' s not rooted I can't download from Google either (and there's no iobit apps in the Amazon store)
    From the News & Offers thread Advanced Mobile Care V2.1 is Released!
    Originally posted by enoskype View Post
    Advanced Mobile Care v2.1 is released!

    Requires Android: 2.2 or up.
    Android Tablets will be supported in AMC v3.0
    Android Tablets are very popular and I'm sure IObit is working hard to finalize a Tablet version so hopefully it won't be long until Advanced Mobile Care version 3.0 is released
    Keep checking (bookmark?) the News & Offers section :smile:

    All the best, woz of oz
    FORUM USAGE GUIDELINES - Read this first
    Description of IObit Forum features and requirements - Reading this is compulsory
    The thread also includes Handy Links

    NEW USER PUBLIC PROFILE POLICY effective on February 01, 2013 !
    It is compulsory to add your OS + Computer Details to your Profile

    Usage of IObit Products
    Information about using IObit software
    Also contains a wealth of diverse information on many different related subjects

    Comment


    • #3
      Hi Woz, wasn't what I wanted to hear *stamps foot and pouts* but thanks for the info and the quick reply. Guess I'll have to wait it out

      Comment

      Working...
      X