Announcement

Collapse
No announcement yet.

Weird problem with Game Booster 2.3 on Windows XP 64 bit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Weird problem with Game Booster 2.3 on Windows XP 64 bit

    I have Windows XP 64 bit, when I run game booster premium 2.3 it says that I already have all gaming essentials installed and system tweaks applied but I don't have ventrillo, teamspeak or xfire installed, its even showing that I already have all system tweaks applied but I didn't click the system tweaks button at all. This problem is affecting me on Windows XP 64 bit but I didn't have this problem on Windows XP 32 bit. Any suggestions? Is Game booster compatible with the 64 bit version of Windows XP? The problem is just that its showing wrong information and I didn't have this bug on Windows XP 32 bit. Please help
    Last edited by Dereck; May. 21st, 2011, 23:37.

  • #2
    Just found a fix to the problem. Seems that Game Booster 2.3 isn't compatible with Windows XP 64 bit. So I reran setup with compatibility settings(Right Click setup > Compatibility > Change to Windows XP) and its fixed. Now its detecting the latest drivers for me and showing correct information but its still not showing gaming essentials for some reason

    Comment


    • #3
      Incompatible with War Rock?

      Good afternoon,

      I'm running Windows 7 home premium 64-bit; Service Pack 1 - and i've been having issues with my game shutting down after 2-5 minutes.

      Whether game booster's set to boost mode or not, I still get the same disconnection error. [The War Rock error is '10501.']

      I only get this issue when game booster is open.

      Any suggestions? I've already tried a complete wipe/re-install/defrag/system restore/and finally reduced myself to reinstalling my operating system. All to no avail.

      Any helpful information would be much appreciated.

      Thank you very much for your time and consideration,
      Fox

      Edit: I forgot to mention: I've been running Game Booster v2.3 Premium.
      Last edited by Trollzlulz; Jun. 7th, 2011, 14:28. Reason: Left something out.

      Comment

      Working...
      X