Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer

SmartDefrag 2.8.1.1221 - Starts Autodefrag even if system is not idle


ektorbarajas

Recommended Posts

Hi.

 

I've noticed a strange issue:

 

I'm normally using my computer and suddenly SmartDefrag starts to Auto Analyze and then to Auto Defrag my drive,

 

I've checked the automatic defrag settings and they are at the suggested values:

- Start Auto Defrag when system idle exceeds (5 minutes)

- Pause Auto Defrag when resource usage exceeds (60%)

 

I even tried to completely uninstall and reinstall SmartDefrag but don't know why it's behaving that way.

 

So I don't know if this is normal (I assume is not since my system has not being idle)

 

Any assistance is appreciated.

Link to comment
Share on other sites

I'm still having this anoying issue, even after installing SD 2.8.1.1221.

 

I don't know why SD starts to analyze and defrag my drive while I'm using my computer, according to the settings this should not happen, SD should only start when the idle settings are met.

 

Please help

Link to comment
Share on other sites

ektorbarajas

 

I can only think that even though you are using your pc, that the resource usage must be so low that SD determines it as idle. As you know, the pc is never completely idle, as the cpu is always active, so SD obviously has a certain percentage of usage plus the time setting, which it uses to determine what idle is.

I recommend that you increase the - Start Auto Defrag when system idle exceeds - to 10 mins

and see if that prevents the issue. If that does not succeed, then you could also try decreasing

- Pause Auto Defrag when resource usage exceeds - to 20%.

 

Personally, I would not recommend using auto defrag, as too frequent defragging can lead to reduced disc life, and increased sector damage. Defragging should be done by doing an analysis once a week and then only defragging if the analysis recommends it.

Link to comment
Share on other sites

Hi Scannan, thanks for your suggestion.

 

I will try different settings and see what happens.

 

BTW what I've noticed is that even SD autodefrag is running and I'm using my computer, it doesn't impact the performance. But just wanted to know if this was a bug or a known issue

 

Regards

Link to comment
Share on other sites

SD is very easy on system resources. When I run a defrag with full optimisation, I never see a reduction in system response. I think that SD has been designed well, and it only uses resources when they are available. You would probably find that the defrag takes a little longer, rather than slow down your system.

 

I do not think that your issue is a known issue. Probably because of the fact that I think that most users do not use auto defrag.

Link to comment
Share on other sites

  • 3 months later...
Hi ektorbarajas,

 

Thanks for your fast reply.

 

To look into the issue, please send us the file config.ini under %appdata%\IObit\Smart Defrag 2\

 

Thanks in advance.

 

Hi Cicely, by checking the forum and pending topics, I realized that I never sent you this file. :oops:

 

BTW, this behavior is still present with the most recent SD 2.9 version.

 

Regards

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...