Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

Windows cannot find 'c:\program files (x86)\iobit\advanced systemcare ultimate\asc.exe'


Recommended Posts

This morning I noticed my computer had restarted. When I logged in, I also discovered Advanced Systemcare ultimate 8 had not loaded. When I click the icon for it I get the message Windows cannot find 'c:\program files (x86)\iobit\advanced systemcare ultimate\asc.exe'. But when I go into file explorer I can see it, but get the same error when I click it. I checked the effective permissions I have full permissions to it. Some of the exe in the same folder work (those with UAC prompt for credentials) with others don't. I have tried to uninstalled, but got the same message. I then ran Malwarebytes rootkit remover and Kapersky rootkit remover and Sophos antivirus and removed a few bad entries. After a reboot, I still got the message, but could uninstall and install it again...still no luck. I tried windows system restore point, but it didn't work (no surprise there). I then tried a utility that sets the permissions on registry, files, services for full control for administrators group...nope. I uninstalled, and installed version 9 of the software, with no luck. I even tried to install it to a different directory. I am able to install malewarebytes and sophos fine. PLEASE HELP!


Link to comment
Share on other sites

Hi mlhend2002,


Welcome to IObit forum. This is Cicely from IObit.


Sorry for the trouble. Please try to find unins000.exe under c:\program files (x86)\iobit\advanced systemcare ultimate, double click to run it and uninstall Advanced SystemCare Ultimate 8 to see if it works. And then install Advanced SystemCare Ultimate 9 from http://www.iobit.com/en/advanced-systemcare-antivirus.php


If the problem remains, please send us the screenshot of the error message so that we can see it clearly. Guide for taking screenshot: http://www.take-a-screenshot.org/


Moreover, please download the tool from http://testdemo.iobit.com/InfoHelperV9.exe


Then double click to run this tool and click “Save report to Desktop”. Then you will get zipped file IObit_Debug_Info on your desktop. Please send it to us so that we can get the detailed information to look into.


Thanks for your time in advance.


Link to comment
Share on other sites

  • 4 years later...

Oh Boy, I have the exact same problem and it is 4 years later than this post. Hope somebody reads it. I've done nearly all that mlhend2002 did, and I even tried to run the unins000.exe and the same error came up. This is making me crazy! I've included the code, but seriously, I just don't know how to live without ASC. The performance monitor works fine. Let me run that testdemo program for you. So, it's only taken me 3 hours to get those files from my sick computer, which by the way is HP Envy i7 laptop, running Win 10 which is current.

Thank you,


Link to comment
Share on other sites

I think that maybe Windows Controlled Folder Access has blocked ASC. Have a look there. If so.. you can unblock it.

Also, possible that Windows Defender has blocked/quarantined it.

Try, temporarily disabling Windows Defender (and any other antivirus/malware programs)....reinstall ASC and see if it works.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...