Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

Advanced WindowsCare 2.40 Official Edition(Available Now)

Tim Xue

Recommended Posts

  • Replies 80
  • Created
  • Last Reply

Tim, Tim, Tim.

I would like you to do a THUROUGH CHECK of system analysis in AWC personal 2.4 beta. I mean i've seen bugs in your product, BUT THIS IS MORE THAN A BUG! This is a MAJOR problem. When scanning, AWC froze on System analysis, and therefore, i had to restart my computer. I am running windows vista, and i just got a new computer, and so i cant afford to screw up this computer, so i uninstalled AWC 2.4 beta and installed the safe version 2.3, but it didnt go away. The system hung on System analysis and froze.This time, i dont know how, but me computer couldnt connect the the internet even though it was plugged. i eventually fixed most issues, but some of my programs STILL CANT CONNECT! Now when i try to run your program to fix this , it isnt working, it opens, and then suddenly closes. This has turned me off your product, and until you can prove to me that your product is safe, dont expect a good review to CNET from me.

Link to comment
Share on other sites

AWC Pro 2.4 hanging on registry scan




Upgraded from 2.3 to 2.4 and the scan hangs (see screenshot attached). Rebootedf and tried again - same thing


Have now gone back to 2.3 to see if that scans OK and it does scan the registry but is hanging on the system scan.


I tried 2.4 on my desktop (all PCs run XP Pro at the latest fix level from MS) and had the same - except that the registry scan hangs on an entery 'Livescripts'


Is anyone else seeing this?


I am going to reinstall 2.4 beta on the laptop and will see if I can find a workaround




Link to comment
Share on other sites

Running v 2.4 Pro on XP. I just updated signature data base 35196. After that AWC would not open. I checked errorlog.txt file and it said "archive file missed,please re-install program. I re-installed and all seems fine now.


Link to comment
Share on other sites

Hi ,

I tried installing Advanced WindowsCare v2 Personal 2.40 beta2 yesterday and Windows closed the installation stating there was an error . I deleted the installation folder before thinking to check for an error log .

Downloaded from Major Geeeks , maybe a problem with the file download getting corrupted , or my system .


I downloaded the 15 day Pro Trial version from the IObit download page , it installed fine though , minutes after the v2 Personal 2.40 beta2 failed installing .


Just wondering if there's been any problems with AWC v2 Personal 2.40 beta2 with anyone else ?


Excellent program by the way


Link to comment
Share on other sites



fantasic work tim and team on version 2.40 version it works great in windows xp but in vista it runs slow the scan i have vista home basic the new registry scan works excellent in xp and vista it fixed all probelms in vista in both program i have to shut down spysweeper with anti virus to allow secitrty defense to work also my vista computer one memory slot broke i have one slot and it has 1gb of ram i have also 2 gb usb stick for readybooster bestbuy told me its like have 3 gb of ram in the computer is this true? i have iolo 7 too it told me to defagment system memory does it harm the computer at all defrag the harddrive ram? oh my sysyem has 250gb of harddrive with a 16 mb cache is this ok? will you add a hard drive tool to your program?

Link to comment
Share on other sites

AWC hangs on registry scan


I upgraded to the latest version of AWC and it hangs on the registry scan at the end. I have uploaded 2 screenshots. One where it hangs forever and the other with the version. Can you fix this? I have not experienced this before. Great work!

Link to comment
Share on other sites

Hi Tim,


After first scan, "Privacy Sweep" does not show any problems but it only finds them after re"Scan".


By the way, I think the word "Rescan" is better on the "Scan" button after the first scan as you have used it before in the old versions. It was giving you the information that you have already scanned once.(Specially if you have closed the AWC application)

The only change needed is one word in English.lng as before.

This behavior is not specific to the new versions.


Also, I repeat my request that you put the version build numbers near the links you supply for the setup files.

Link to comment
Share on other sites

Uninstall/Install of 2.4 Betas Deleted IE7 Trusted Sites


The uninstall and re-installation of 2.4.0 Betas (Pro) always deletes all the Trusted Sites that I have in IE7 Trusted Sites. This is on Windows XP-SP2 Home Edition. I have "Require server verification (https:) for all sites in this zone" unchecked and run with several http: entries in "Trusted Sites".

Link to comment
Share on other sites

Hi, I have noticed that in the system analysis displayed results, there is an extra column that you can access if you click to the right side of the divider on the current value frame. If you unclick, however, it snaps back. If you click to the left, however, yet another column opens but this one does not snap back.

Link to comment
Share on other sites

Giveawayoftheday issue!!!!!




I understand the limitations of the Giveawayoftheday program back in February. However, the program is no better than the personal edition since auto updates do NOT work properly.

If I attempt to update, I keep getting a message stating that the license has expired!!!

Other forums also report this behavior.


So, it seems that you were paid for programs by Giveawayoftheday, but people who downloaded and installed this program, thinking that they were getting a valid program, got the raw end of the deal!


So, my question is, why was a disabled edition of the program put up for download, without explaining the limitations?


Thank you

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...