Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

The installer is not working anymore for me I get an error


Recommended Posts



This goes for Iobit advanced systemcare as well :(


I downloaded the most recent installers and they uninstalled the program and then go on to give the error shown in the screenshot.

Now I don't have the software anymore AND I cannot install it anymore :S


Retrying doesn't work and if I ignore I get an endless slew of errors when I try to use the program.

And I get this same error on several stages of the installation process.

I never had any of these issues before with your software.


It's very sad because I love your products but now it's become completely unusable.

What's interesting as well is that it happens for both softwares, why would this be?

Link to comment
Share on other sites

Hmm can't remember I've had these installers on my computer for a few weeks now. It took weeks to get access to this forum so I can't remember.

But I'm pretty sure I got redirected to wherever I downloaded it from by the Update prompt I got that there was a new version available so I have to assume that's legit.

So it's the same place I've been downloading them from for years.


My Comodo antivirus program was completely disabled and so were all my windows protection funtionalities.

Link to comment
Share on other sites

Yeah I did and I still get the same error.

The installer is the exact same file as I got from where I downloaded it from previously which is where you get lead to by iobit when it says there's an update.

But that place was not majorgeeks that's true but why would the software itself lead you to a bad source?


Error ->https://imgur.com/RTLdv0L

Proof of where I downloaded it ->https://imgur.com/a/f2OIEYj

Windows protection is off -> https://imgur.com/l9xCVBV

Windows Fire wall is off -> https://imgur.com/cZDdEdS

Antivirus Comodo is off -> https://imgur.com/yeS47gK


It will just hang on 99% and if I hit ignore then the program acts like it's installed but it's not.

The shortcut leads to nowhere and the program is nowhere to be found.


This happens for both Iobit uninstaller and advanced system care.

Link to comment
Share on other sites

The software can lead to a bad source because Iobit use third party re-sellers, who can add their own ads/pups....

Majorgeeks is the only really trusted site.

As regards your problem, as you have disabled windows defender, it would be a good idea to look into your Controlled Folder Access. People forget about this, and it can be very aggressive in blocking a programs access to the necessary folders. I know that it reacts to Iobit files, as I have had to open Controlled Folder Access and allow some iobit files to have access.

Worth a try. The other thing to try if that does not solve the issue, is to try installing the program(s) in Safe Mode.


Link to comment
Share on other sites

  • 2 weeks later...

Firstly...this is not Our software.......it is Iobits Software.....this is a help Forum and we are volunteers trying to help users.

If you go to the News & Offers section of the Forum, you will see that the link(s) to download the products are for Majorgeeks.

The majority of companies, use third party re-sellers to market their software....and these third parties often add their own ads/pups to the download.

That is why most sensible people do not use automatic update, but rather go to a reputable site to download updates.

So, hopefully you are now clear. No point in trying to hassle Iobit to change their policies, because they will not. We have tried.

Link to comment
Share on other sites

Ah I see, I apologize for assuming, I can see this is a point of returning frustration for you guys.


As for your suggested fixes, due to the holidays I've not yet had time to sit down and look into it.

I need my head to be clear to be able to focus on troubleshooting as it usually frustrates me to no end.


But yeah I'm clear, the website seems very useful and I've already found some other helpful software there.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...