Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

SmartRAM.ini problem


Recommended Posts

Hi. I use Advanced System Care Free (latest updated version) on my Vista.

When I click on Smart RAM I have an error message saying:

"Unable to write to C:\Documents and Settings\ReleaseEngineer.MACROVISION\Application Data\IObit\SmartRAM\SmartRAM.ini."

If I click "Ok" SmartRAM opens but If I click on "Settings", I modify something and I click "Ok" this error message appears again. So I can't modify any setting. Why?

I already tried to uninstall the program and install it again.

What can I do? :sad:

Link to comment
Share on other sites

Hi danzel,


Are you using the PC as Administrator?


Also, some other security software may protect the ini files. Check if you can temporarily turn off the security softwares you are using.

Also try to modify SmartRAM.ini manualy, and see if you have a right to do that.



Link to comment
Share on other sites

Thank you for your reply. Yes, I use the PC as administrator.

I tried to disable the antivirus software but the problem remains.

I searched for the SmartRAM.ini file but I didn't find it. Vista doesn't have the "Documents and Settings" folder but I think that the "Users" folder is the same thing. So I went to:

"C:\Users\[MY PC NAME]\AppData\Roaming\IObit"

But I don't have any "SmartRAM" folder here and absolutely any "SmartRam.ini" file.

I opened the same path on my second computer (a Vista, with the same version of Advanced System Care installed) and there I found the "SmartRAM" folder and the "SmartRam.ini" file! (On this second computer Smart RAM works perfectly, without errors)

I copy the folder with the file from my second PC to my first one, I rebooted the computer but the error message still appears... :sad: So?

Sorry but I can't understand: why does the program search for the file at this path (C:\Documents and Settings\ReleaseEngineer.MACROVISION\Application Data\IObit\SmartRAM\SmartRAM.ini) if my pc name is not "ReleaseEngineer.MACROVISION"??

Link to comment
Share on other sites

That is really strange Danzel. :-o


There must be something wrong in the registry.


Is there a chance that this specific PC is upgraded from XP to Vista where the User in XP had a name "ReleaseEngineer.MACROVISION"?


Just for an experiment, copy the SmartRAM. ini, creating the path and the folders which SmartRAM can not find. ei.:

C:\Documents and Settings\ReleaseEngineer.MACROVISION\Application Data\IObit\SmartRAM\SmartRAM.ini


and try the Smart RAM settings.


Does all the other functions of ASC work as they should?


I believe, this case should be investigated by IObit.



Link to comment
Share on other sites

No, the PC is not upgraded and it didn't have another name, It's new, I bought it few months ago. It already had Vista and I never changed the computer's name. I can't understand what "ReleaseEngineer.MACROVISION" is...

I tried the experiment you suggested but it didn't success. I created a new folder in C: and in the folder name field I wrote "Documents and Settings" but when I press Enter a message appeared, saying that the files of this new folder would be moved to the "Users" folder, and then the new folder disappeared. So... Vista doesn't allow me to create this path.

Any idea? :sad:

I think other functions of ASC work well, all the other functions I tried at least.

I would like to send an e-mail to IObit but I didn't find any contact address on the official site.

Link to comment
Share on other sites

For Your Information


I Googled ReleaseEngineer.MACROVISION and found this thread which may be of interest.


Note: Please wait for enoskype to comment.

I am not saying this is a solution, it involves editing the Registry and so I offer no opinion.

I just thought it was interesting especially if you have downloaded some MP3 from Walmart.


Anyway here is the thread:



All the best, woz of oz

Link to comment
Share on other sites

I don't even know what Macrovision and Walmart are. I found in google some other discussions about people having a similar problem, but with different softwares. But I still don't understand what can I do and what this "ReleaseEngineer.MACROVISION" is. I prefer not to edit the registry, or do it only if necessary. I read someone has resolved by creating a new account, deleting the old one. I wait for some advice... :-(

Link to comment
Share on other sites

Hi Danzel,


We can try the changes that wozofoz pointed out,


Before changing anything in the registry, let's find out the entry values for those Registries.


Please post exactly what ara the values of the following in your Registry Editor.


1) Data(Value) for Type REG_EXPAND_SZ of:


Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders=>AppData


2) Data(Value) for Type REG_SZ of:

Computer\HKEY_CURRENT_USER\Volatile Environment=>APPDATA


They should be:


Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders=>AppData => %USERPROFILE%\AppData\Roaming




Computer\HKEY_CURRENT_USER\Volatile Environment=>APPDATA => C:\Users\{Your User Name}\AppData\Roaming




If they are like the above, then you can try the creation of the new User Account solution.


If the registry values are not like above then, you can try to change the values, first taking backup of those registries.


To go to Registry Editor, click "Start" on the Taskbar, click "Run...", type regedit, click "OK".

Registry Editor window will open. Go to the Registry entries written above. You can read the values to compare.


To backup and edit the concerned Registries:


Right click on User Shell Folders, click "Export" on the menu and save where ever you like in case to change this entry to it's original. Double clicking the ".reg" file you have saved, will change the value to original.

Right click on AppData, click Modify... on the menu, change "Value Data:" to %USERPROFILE%\AppData\Roaming in "Edit String" window, click "OK".



Right click on Volatile Environment, click "Export" on the menu and save where ever you like in case to change this entry to it's original. Double clicking the ".reg" file you have saved, will change the value to original.

Right click on APPDATA, click Modify... on the menu, change "Value Data:" to C:\Users\{Your User Name}\AppData\Roaming in "Edit String" window, click "OK".


Close the Registry Editor, and try SmartRAM again. Please post back the result.



Link to comment
Share on other sites

First, thank you all. In the registry the values are correct, any need to change them. So I can try to create a new account, following the instructions written in the thread posted by wozofoz. If this solution works and I delete the old account... I can lose everything important or just the account configurations and settings? The thread says: "Backup your data", which data I need to backup?

Link to comment
Share on other sites

Done. I created a new account and now SmartRam works without problems.

So I will copy my desktop configurations and my personal data (images, documents, downloads, etc) from my old account to the new one and then I will delete the old account. Thank you again. :wink:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...