Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Advanced SystemCare Pro Review IObit Coupons A Good Utility Program From IObit IObit Driver Booster Pro Review IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs IObit Software Coupons & Promo Code

Windows Vista blocks SmartRAM from starting at Windows startup?


George Lass

Recommended Posts

Hi,

 

I've checked IOBit's checkbox that they have included (to enable SmartRAM to automatically startup when I boot up my computer in the morning). But alas, Windows Vista BLOCKS IOBit's program, Suo10_SmartRAM.exe from starting up. IOBit is very clever indeed to give me this checkbox to check because SmartRAM starting up automatically everytime I start up my Windows Vista Ultimate computer is incredibly desireable to me and the world to use and enjoy. Thank you IOBit.

 

In my Windows XP Home and XP Professional computer(s), I check IOBit's supplied checkbox to have SmartRAM startup each and everytime that I boot up the computer, and by golly, it works fantastic. I love it!!!

 

It's just that this feature of IOBit's Advanced System Care V4 doesn't work in Windows Vista. Windows Vista "Blocks" the program Suo10_SmartRAM.exe from automatically starting up every time I boot up Windows Vista even though I have checked IOBit's supplied check box that tells SmartRAM to automatically run each time Windows is started.

 

I am puzzled.

 

In Windows Defender ---> Software Explorer ---> Category ---> Startup Programs ---> IOBit ---> SmartRAM --->

 

it says this...

 

File Name: Suo10_SmartRAM.exe

Display Name: Smart RAM

Description: Monitors and Optimizes memory usage to increase available physical memory.

Publisher: IObit

Digitally Signed By: VeriSign Class 3 Code Signing 2009-2 CA

File Type: Application

Startup Value: C:\Program Files\IObit\Advanced SystemCare 4\Suo10_SmartRAM.exe /m

File Path: C:\Program Files\IObit\Advanced SystemCare 4\Suo10_SmartRAM.exe

File Size: 512400

File Version: 2.0.2.384

Date Installed: 4/23/2011 11:14:39 PM

Startup Type: Registry: Current User

Location: Software\Microsoft\Windows\CurrentVersion\Run

Classification: Permitted

Ships with Operating System: No

 

 

This looks really good to me, and "Classification: Permitted" looks swell also, it's just that, and darned if I know why IOBit's check box doesn't work in Vista, IOBit's SmartRAM program won't automatically start up when I boot up my Vista computer, even though I've checked the checkbox for SmartRAM ---> Settings ---> Option ---> Run at Windows Startup.

 

Windows Vista keeps saying that "Windows has blocked some programs from starting" when I boot up my computer in the morning. (something like that).

 

Is this a bug in IOBit's SmartRAM program?

Or should IOBit's checkbox not be there?

 

I don't know.

I'm confused.

 

George

Link to comment
Share on other sites

  • 3 weeks later...

Hi George Lass, welcome to IObit Forum! :grin:

 

I have seen that in couple of PCs with Vista as OS.

 

I would try to Clean Install ASC4, which is also explained in Usage of IObit Products , when UAC is turned off in Vista and after installation, right click on Suo10_SmartRAM.exe and choose "Run As Administrator".

 

UAC does similar glitches for some other software too. There are free programs to change UAC behaviour in Vista such as UAC Controller Tool 1.0 to behave like in Windows7, so it will not be that much intrusive.

 

Cheers.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...