Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer

Automatic Defrag Checkbox [FIXED]


Zatronium

Recommended Posts

  • Replies 57
  • Created
  • Last Reply

Well, so much for that theory...I just opened the program back up and then looked at the config.ini and this is what I see:

 

EnableAutoDefrag=1

AutoDefragVolumes=

 

BTW, I have had the checkbox enabled which says "Minimize to system tray when program is closed". If I uncheck that box then close the program, then the config.ini file looks good, however the GUI still says "NO" when I re-open the program.

 

So, if you ask me, the problem is related to having the program minimized to the tray when it is closed.

Link to comment
Share on other sites

Hi am_dew

You gave a screenshot of the program window - I meant the settings window, sorry.

In your screenshot there is no disc selected - could that be the reason it says no to the automatic defrag perhaps?

Cheers

solbjerg

 

http://www.panix.com/~am_dew/sd.jpg

 

I have also attached my config.ini file which has been renamed to config.txt.

Link to comment
Share on other sites

Hi am_dew

You gave a screenshot of the program window - I meant the settings window, sorry.

In your screenshot there is no disc selected - could that be the reason it says no to the automatic defrag perhaps?

Cheers

solbjerg

 

Which screen in the "Settings" would you like to see?

 

Here is the "Automatic Defrag screen:

 

http://www.panix.com/~am_dew/sd2.jpg

 

As for no disc being selected in the screenshot, is checking that box required in order to turn on Auto Defrag? The Yes/No toggles without it being selected, so I did not think so...you will have to tell me what the correct procedure is.

Link to comment
Share on other sites

If I check the boxes on the main screen, they stay checked and "Auto Defrag" stays on "YES", however those things only stay that way until the system is rebooted. After a reboot, the checkboxes are gone and the "Auto Defrag" says "NO". However, my config.ini file still has the drives set up for Auto Defrag.

 

So, I think we're getting somewhere...the state of the Auto Defrag "YES/NO" setting on the main screen is not shown correctly as to how the config.ini file settings are.

Link to comment
Share on other sites

Hi am_dew

I almost never use the auto-defrag function and almost exclusively to test what my machine will do when others have problems with the program.

So in accordance with your request that I try it - I did.

I set the settings to use autodefrag with the idle time of 1 minute, and I ticked the No in the program window to change it into Yes.

Then I waited for 5-15 minutes until it showed that it had performed the auto-defrag - the previous one was in July 2011.

Then I restarted my machine and all the settings were as they should be - it said that the C: drive was chosen, and that the auto-defrag was turned On and the Yes still stood ther in green colour.

The only thing I wondered about were the fact that when hovering over the icon in the taskbar it didn't show the latest defrag day and time as it had done prior to the restart - but it did show it if I opened the program window..

So all in all I cannot reproduce your results.

I have my defrag settings set to start at 3% fragmentation, but I do not know how often or at what criteria the auto-defrag kicks in.

Cheers

solbjerg

 

 

If I check the boxes on the main screen, they stay checked and "Auto Defrag" stays on "YES", however those things only stay that way until the system is rebooted. After a reboot, the checkboxes are gone and the "Auto Defrag" says "NO". However, my config.ini file still has the drives set up for Auto Defrag.

 

So, I think we're getting somewhere...the state of the Auto Defrag "YES/NO" setting on the main screen is not shown correctly as to how the config.ini file settings are.

Link to comment
Share on other sites

Hi am_dew

I almost never use the auto-defrag function and almost exclusively to test what my machine will do when others have problems with the program.

So in accordance with your request that I try it - I did.

I set the settings to use autodefrag with the idle time of 1 minute, and I ticked the No in the program window to change it into Yes.

Then I waited for 5-15 minutes until it showed that it had performed the auto-defrag - the previous one was in July 2011.

Then I restarted my machine and all the settings were as they should be - it said that the C: drive was chosen, and that the auto-defrag was turned On and the Yes still stood ther in green colour.

The only thing I wondered about were the fact that when hovering over the icon in the taskbar it didn't show the latest defrag day and time as it had done prior to the restart - but it did show it if I opened the program window..

So all in all I cannot reproduce your results.

I have my defrag settings set to start at 3% fragmentation, but I do not know how often or at what criteria the auto-defrag kicks in.

Cheers

solbjerg

 

I think the difference between your test and my situation is that I have an SSD and other HDD. Not sure how or why that would make a difference, but apparently it does because I also tested the program on a machine I am setting up for a freind which only has a single HDD and the settings stayed as they should, both in the config.ini and the GUI.

Link to comment
Share on other sites

Hi am_dew

I did notice that you also had a SSD but didn't expect you to try to defrag that disc.

In order to get the full picture of your settings would you also please provide a screenshot of your general settings. Thanks!

Cheers

solbjerg

 

Toppack, I completely agree and have no intent on letting SD defrag it! I was just pointing out that I do have one.
Link to comment
Share on other sites

Hi am_dew

I did notice that you also had a SSD but didn't expect you to try to defrag that disc.

In order to get the full picture of your settings would you also please provide a screenshot of your general settings. Thanks!

Cheers

solbjerg

 

Sure thing...

 

http://www.panix.com/~am_dew/sd3.jpg

Link to comment
Share on other sites

Hi am_dew

Thanks - but didn't help understanding your problem unfortunately. :-)

Looks almost exactly like mine except that I don't have tooltips ticked on this machine - I do on my laptop though.

Cheers

solbjerg

p.s. Just noticed that the choice of fragmentation rate is in ASC :roll:

Link to comment
Share on other sites

Hi am_dew,

 

We have done the test on a PC with SSD, but we can not reproduce it,:-( so please kindly help us look into it.

 

1) Please download the SmartDefrag (new).zip and extract it to get SmartDefrag (new).exe, then put the SmartDefrag (new).exe in the Smart Defrag installation folder.

 

Usual path: C:\Program Files\IObit\Smart Defrag 2 or C:\Program Files (x86)\IObit\Smart Defrag 2

 

2) Please double click SmartDefrag (new).exe to run it, then find and send the SmartDefrag_test.txt in the installation folder.

 

Thanks in advance!:wink:

SmartDefrag (new).zip

Link to comment
Share on other sites

Hi am_dew,

 

We have done the test on a PC with SSD, but we can not reproduce it,:-( so please kindly help us look into it.

 

1) Please download the SmartDefrag (new).zip and extract it to get SmartDefrag (new).exe, then put the SmartDefrag (new).exe in the Smart Defrag installation folder.

 

Usual path: C:\Program Files\IObit\Smart Defrag 2 or C:\Program Files (x86)\IObit\Smart Defrag 2

 

2) Please double click SmartDefrag (new).exe to run it, then find and send the SmartDefrag_test.txt in the installation folder.

 

Thanks in advance!:wink:

 

Attached is the file. Did you also test on a PC with multiple hard drives/partitions?

SmartDefrag_test.txt

Link to comment
Share on other sites

Not many people have Both a SSD And a Non-SSD in their computers, to test for this problem. :sad:

Cicely said that they tested it with a SSD, but Not that they tested with Both

and I think having Both is what is causing the problem in the program code.

 

I'm sure IObit has many other Bugs they are Franticly working on now,

but maybe they can get to this one soon. :lol:

Link to comment
Share on other sites

Is this a dead issue? If so, I will uninstall the program sinceI was drawn to it because of the Auto-Defrag feature. Windows Defrag can do the normal scheduled defrags just fine. Thanks.

 

IObit made the effort to provide you with the SmartDefrag (new).zip so they are obviously interested in this issue.

I am sure Cicely will reply once your report file has been analyzed and possible solutions have been looked at :smile:

 

All the best, woz of oz

Link to comment
Share on other sites

Just to say I have the same problem with v2.3. The auto defrag and boot time defrag do not stay as YES in the GUI for my two HDD's after stopping and restarting Smart Defrag.

 

I have two SSD's and two HDD's on my Win 7 64bit system.

 

This was not an issue with v2.2, which I have reinstalled and it works perfectly.

 

Thanks

Link to comment
Share on other sites

I presume this is already being dealt with, thanks to the other user that posted, but I'll do as I was instructed anyway.

 

I just downloaded v2.3, and the problem still appears to be present. Thanks again for the correspondence.

 

Edit: Oops, didn't notice the 5 pages of posts. I subscribed to this so I'll stop forgetting about it.

DriveCheck_Method1.txt

SD23.zip

Link to comment
Share on other sites

Hi am_dew and Zatronium,

 

We are very sorry, we have not worked out a solution to this issue, we are still on the way to the right answer.:cry:

 

We have looked into the SmartDefrag_test.txt sent by am_dew, but we didn't find the cause. So we still need your help to confirm when and how does this issue occur.:oops:

 

1) Please open Smart Defrag and turn on the Automatic Defrag, then go to the Config.ini in the Smart Defrag profile folder and take a screen shot of the AutoDefragVolumes as the attached picture.

 

Usual path: %appdata%\iobit\Smart Defrag 2

 

2) Please close the the Config.ini and exit Smart Defrag, then go to the Config.ini and take a screen shot of the AutoDefragVolumes.

 

3) Please restart the Smart Defrag and don't do any action, please just go to the Config.ini and take a screen shot of the AutoDefragVolumes.

 

Note: please let us see the things behind the "AutoDefragVolumes=" in the screen shot.:!:

 

Thanks a million!

Link to comment
Share on other sites

I did as requested...there was no change in the "AutoDefragVolumes=" setting.

 

Before:

EnableAutoDefrag=1

AutoDefragVolumes=J:\;K:\;L:\;M:\;N:\;O:\;P:\;Q:\;X:\;

 

After:

EnableAutoDefrag=1

AutoDefragVolumes=J:\;K:\;L:\;M:\;N:\;O:\;P:\;Q:\;X:\;

Link to comment
Share on other sites

Step 1:

AutoDefragVolumes=D:\;

 

Step 2:

AutoDefragVolumes=D:\;

 

Step 3:

AutoDefragVolumes=D:\;

 

Same result as am_dew, no changes in the file contents. If you really need a screenshot, I can do that too. But I haven't installed a screenshot program, and manually resizing 3 screenshots is annoying.

Link to comment
Share on other sites

Any update on this issue?

 

Hi,

 

Any update from IObit staff on finding a solution for why the Smart Derag UI does not display the correct drive settings for auto/boot defrag when there is an SSD on the system?

 

Happy to provide additional data if it is helpful.

 

Thanks

Link to comment
Share on other sites

  • 2 weeks later...

Dear friends,

 

We are so sorry for the delay of reply to the issue, :oops:our engineers have worked out a test to look into this issue, please kindly help us test it.

 

1) Please download the SmartDefrag2.zip and extract it to get SmartDefrag2.exe.

 

2) Put it in the installation folder of ASC, then double click it to run it.

 

Usual Path: C:\Program Files\IObit\Smart Defrag 2 or C:\Program Files (x86)\IObit\Smart Defrag 2

 

3) Please find and send us the SmartDefrag_test.txt in the installation folder of ASC.

 

Thanks in advance!:wink:

SmartDefrag2.zip

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...