Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

Some mouse buttons not working in-game

Recommended Posts

I just downloaded the software and everything seems to be working great. The only issue I've run into so far is that when I run the game boost and start Halo 2, some of the buttons on my mouse don't register in-game. I have a 5-button explorer mouse. It reads the left, right, and scroll buttons but not the two on the side. I looked at the list of changes the gameboost made and I can't figure out what the problem could be.


I attached a picture of the items I checked. The two services I checked are realsched.exe and jusched.exe and there are no non-windows services checked. I'm also running the advanced systemcare turbo boost but it's only when I'm running the gameboost that the issue arises.

Link to comment
Share on other sites

hm, looks like my pictures are really small and unreadable. Here's the list of checked items:


Unnecessary Services:


Application Experience

Computer Browser

Function Discovery Provider Hose

Function Discovery Resource Publication

IPsec Policy Agent

Microsoft Software Shadow Copy Provider

Peer Name Resolution Protocol

Peer Networking Identity Manager

Print Spooler

Program Compatibility Assistant Service

Remote Desktop Services

SSDP Discovery

Windows Media Player Network Sharing Service





Launch Game on Game Desktop

Clean RAM

Clear clipboard

Enable game power solutions

Turn off Automatic Updates

Link to comment
Share on other sites

I'm guessing you have a program running for your mouse? If it's Logitech then you'll have something called 'Logitech Gaming Software'. Have a look to see if Game Booster shuts down the program that is used for your mouse. If the program is checked then uncheck it.

Link to comment
Share on other sites

Looks like the issue was simply with the Game Booster Window itself. When it was open those button didn't work. I didn't think of that because it was supposed to minimize itself after 10 seconds. So instead opening a game automatically after boosting, I boosted manually and minimized it (also, the auto-minimize works too when not starting a game... I guess it must not have minimized when the game initialized. maybe it conflicted with a process shut down?...) and THEN started the game (once it had fully minimized) the buttons worked again. Also, it wasn't just the mouse buttons; I was trying to use my left control button on the keyboard for voice chat and it didn't work when the GB window was open. But now all is well (for now...)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...