Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Advanced SystemCare Pro Review IObit Coupons A Good Utility Program From IObit IObit Driver Booster Pro Review IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs IObit Software Coupons & Promo Code

Smart Defrag "hangs"


CRGibson

Recommended Posts

Just downloaded and have been trying Smart Defrag v 1.0. I can not get beyound 16% Analyzing OR Defraging. It seems to "hang" on the same file. Have tried uninstalling, rebooting, running Advanced Windows and then rebooting but nothing helps. Running XP SP3. Sure could use some help.

Thanks

Link to comment
Share on other sites

Hi there

 

Kindly write back to us and provide us with the following information so that we can further investigate this concern:

 

- We need pictures of the trouble you got. Pictures of your trouble will be much helpful. If possible, please send some pictures to us for clearly investigation.

 

Guides for Taking Screen Shots:

 

http://www.microsoft.com/windowsxp/using/setup/tips/screenshot.mspx

 

http://graphicssoft.about.com/cs/general/ht/winscreenshot.htm

 

 

 

- Open program directory (Usually path: "C:\Program Files\IObit\IObit SmartDefrag"), and find a file named "bugreport.txt". Please send this file to us.

 

Thank you for your patience and we look forward to hearing from you soon.

Link to comment
Share on other sites

Hi Sweetalker and CRGibson,

 

When IObit is looking after that if there is something in SD, can you cut and paste the files that the SmartDefrag hangs, to another drive and try to defrag again.

If the defrag continues, you can cut and paste back the same files to their original drives.

With that action, they will be located to the original drive as defragmented and it wil be understood that the reason of the hanging was because of the files.

 

The other thing to try is, try the original Windows defragmenter first and use SD for consecutive defrags and see what it shows in SD GUI.

 

I hope this helps, cheers.

 

Note for CRGibson:

If you type 8 and ) in this order following each other, the result is 8).

Type space after #8 or before ).

I assume you have 18 drives, right?

Link to comment
Share on other sites

enoskype -

I ran windows defrager then tried Smart Defrag again. Still stops at same file. I cut the file and put into another drive (the orginal file was still in the orginal place and also in the new drive). Ran SD again and it still stopped at the same file. Tried again but the popup stated the the file was in use and could not be moved. Attached are the first 5 drives screenshots. I only get 3 drives that are 100% scanned and 3 that do not even start. I have 10 drives that are all mp3 files (Old Time Radio programs). Do you want screenshots of the remaining drives?

Link to comment
Share on other sites

Hi again,

 

Thanks for the screenshots.

The common thing is that all concerned files are image files.

 

Most probably the one in C: is for your Logitech mouse if you are not using any other Logitech hardware, and since you are using it, you may not be able to delete it, otherwise your mouse may not work (low probability though), and you can't work on your PC.

Using a program like "Unlocker", you can delete the file on next boot also.

If you have another mouse, you can try to copy that file to an other place in your PC, and delete it and than try what you have tried in your above post with the other mouse.

Try using the same thing for other files, this time with copying, deleting the original, and copying the copy to original place from other drives and see what happens..

 

I believe the sreenshots are enough for IObit, and please keep arousing interest of IObit Guy and e-mail directly to IObit.

 

Cheers.

Link to comment
Share on other sites

Also hanging

 

First off a fairly neat program, although a little iffy with my wife's external drive - took a couple of tries to get if defragged. The main problem I have is that SD hangs with it's window open even when it is not doing anything, most particularly after the defrag has completed, trying to do anything even just moving the window produces the default sound. This tends to last for some considerable time until either it unhangs itself or I kill it via the task manager. Incidentally SD shows as using 0% of the CPU and is shown as running in the task manager. An annoyance really.

 

Steve

Link to comment
Share on other sites

enoskype -

Thanks for your help. I tried moving the file that stopped SD on my N drive. SD still stopped at the 83%, of course at a different file. I moved that file and SD stopped at 83% on another files. Tried 5 times. Same result. I have 56 folders and 4142 files on that drive - all mp3. As you stated SD stops on ico, bmp and jpg files BUT only on some drives. A few drives do not get beyound analyzing (see drive E attachment on my last message (all mp3 files) - I then when back and ran Windows defrager AND Diskeeper defrager on this drive and again tried SD and it still would not get past the analyzing stage (0%).

It sounds as if I will have wait for a new version. I like the "layout" and how it works on a few of my drives thro.

 

Thanks for you help.

Link to comment
Share on other sites

  • 3 weeks later...

SmartDefrag hangs 4 me 2

 

Downloaded and installed w/o problems.

 

Analyze C: hangs at 8% every time

1st time on an inuse system file for HP scanner. Deleted file.

2nd time on a file in Recycle Bin. Deleted file.

3rd time on a file in System Restore. Turned off System Restore to delete restore point files.

Now hangs on C:\hp\drivers\lan_nVidia\nvsnpu.sys

 

Still at 8%

HDD light not flashing. CPU usage at 0%.

 

Ran CHKDSK C: /F /R (Files in use... ran at next boot)

Ran Scandisk from Properties -> Tools on C: (Files in use... ran at next boot)

 

Still hangs at 8% on same file. Suggestions?

Link to comment
Share on other sites

Hi all

Phrynguser, soapietrekkers and CRGibson

 

I have only two disks C: and D: but I have a some gigabytes pictures. I have never had any trouble with the defrag.

 

Two qestions:

Have you all tried a clean install? Do you all have autodefrag running in the background while you perform a manual defrag?

Cheers

solbjerg

 

BTW, no bugreport.txt in C:\Program Files\IObit\IObit SmartDefrag
Link to comment
Share on other sites

Hi all

Phrynguser, soapietrekkers and CRGibson

 

I have only two disks C: and D: but I have a some gigabytes pictures. I have never had any trouble with the defrag.

 

Two qestions:

Have you all tried a clean install? Do you all have autodefrag running in the background while you perform a manual defrag?

Cheers

solbjerg

Haven't done "clean install", but have never used the program before, so the install should have been clean to begin with (I assume you mean vs upgrade).

 

Autodefrag is turned on by default, so I hadn't changed that setting. Turned off and tried again... still hangs at 8% on same file.

Link to comment
Share on other sites

Ok phrynguser

I have no answer

Hopefully IObit has a solution to the problem.

Cheers

solbjerg

 

 

Haven't done "clean install", but have never used the program before, so the install should have been clean to begin with (I assume you mean vs upgrade).

 

Autodefrag is turned on by default, so I hadn't changed that setting. Turned off and tried again... still hangs at 8% on same file.

Link to comment
Share on other sites

Hello,

 

We find that most Smart Defrag "Hang" cases were caused by background real-time security software. Could you please do a test:

 

Temporarily exit or disable your background real-time security software, like Antivirus, Anti-spyware. Then try Smart Defrag, and see if it hangs.

Link to comment
Share on other sites

Hello,

 

We find that most Smart Defrag "Hang" cases were caused by background real-time security software. Could you please do a test:

 

Temporarily exit or disable your background real-time security software, like Antivirus, Anti-spyware. Then try Smart Defrag, and see if it hangs.

I use AVG anti-virus (free version), ZoneAlarm firewall (free version), Windows Defender anti-spyware. Disabling all 3 made no difference. Still hangs at 8% in analyzing, on the same file.

Link to comment
Share on other sites

ZoneAlarm is the cause

 

I have the exact same problem as others have indicated. My defrag stops at 5% on the exact same file every time. I have also done the same as others by deleting the file, moving it, all to no avail. I also shut down ZoneAlarm, and the defrag still "hung" at the same point. I believe that you will find that this behavior is a current incompatibility with ZoneAlarm. If you completely uninstall ZoneAlarm, SmartDefrag will work flawlessly. I have reported this finding to IOBit, and hope that they are working on a solution. In my case, I uninstalled ZoneAlarm, ran a full defragmentation, then re-installed ZoneAlarm. Once ZoneAlarm was reinstalled, the problem returned just as before. I don't understand why something in the background continues to linger after you have shut down all ZoneAlarm functions, but I found that SmartDefrag will only run successfully after a full uninstall of ZoneAlarm. I am running ZoneAlarm Security Suite, but I believe it is an incompatibility with several of their products, including the free version of their firewall.

Link to comment
Share on other sites

I've read in a Dutch computer magazine that there are issues with AVG.

The AVG 8 version seems to include a so called security toolbar. According to the computer magazine there are several reports of problems caused by that toolbar. It is a wide range of problems not only defrag issues.

 

So probably it may help if you uninstall it if you have that toolbar installed.

Link to comment
Share on other sites

  • 2 weeks later...

SmartDefrag vs ZoneAlarm vs AVG

 

Uninstalled ZoneAlarm free firewall temporarily (for other reasons) and SmartDefrag does indeed work fine.

 

Have never installed AVG toolbar, but SmartDefrag works fine with just basic (free) AVG anti-virus

 

I need ZoneAlarm more than I do SmartDefrag, so if this is not resolved, I will have to get rid of SmartDefrag.

Link to comment
Share on other sites

SmartDefrag vs Zonealarm free

 

After uninstalling Zonealarm free firewall and successfully running SmartDefrag v1.0, I reinstalled Zonealarm. Now the tray icon indicates that SmartDefrag is running successfully on an ongoing basis in the background.

Just so you know.

 

Haven't tried re-running an on-demand defrag since.

Link to comment
Share on other sites

Smart Defrag 1.01 failure

 

I just updated to 1.01 today and Smart Defrag froze up. I hope the Bug Report is attached. By the Way, why don't you leave up the previous version in your download area whenever you post an updated version so that a person can revert back to the older version when troubles prevent the newer version from working correctly? Anyway, thanks for the free software. It has worked fine until today.

bugreport.txt

Link to comment
Share on other sites

  • 1 year later...

I am having the same problem with Smart Defrag frozen at %96. No specific file is scanned during the time of freeze. No bugreport in the folder. Win 7 Pro OS, Avira Antivir 9.xx free version installed. No zone alarm, only Norton IS.

When I say Stop after hanging up it says "Stopping" bu takes forever...I have to kill the thread by Task manager..

No solution yet. Thanks.

Link to comment
Share on other sites

Hello,

 

We find that most Smart Defrag "Hang" cases were caused by background real-time security software. Could you please do a test:

 

Temporarily exit or disable your background real-time security software, like Antivirus, Anti-spyware. Then try Smart Defrag, and see if it hangs.

 

Hi freebird_76,

 

Did you apply IObit Guy's advice?

 

Cheers.

Link to comment
Share on other sites

i would delete iobit defrag and try a couple of other free defrag programs if they work then the problem is iobit and you may have to wait till the next version.

 

if other defrags are hanging then the problem is yours, have you tried defrag in safemode?

 

try these two defrags they are both highly rated

 

free trial 30 days disk keeper 2010

http://www.diskeeper.com/landing/landing30.aspx?RId=11200&Apid=PPS0005174&gclid=CLzE-cujiJ8CFZQA4wod0navJQ

 

jk mydefrag free

http://www.mydefrag.com/

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...