Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

runtime error in SmartRam


Recommended Posts

Sometimes I get this error when SmartRam starts up:

a window opens that says:

"Unable to set data" - SmartRam


What causes this and what can I do to fix it?


SmartRam DOES startup OK and appears to work just fine...so I don't understand this error.


I am running AWC Pro v. 3.0.1 on a Windows XP Pro SP2 "w/all updates" machine.


Thank you.

Link to comment
Share on other sites

Hi Kailasa108,


Please read this thread . Exit Smart RAM from system tray and install ASC 3.11 downloadable from here . In the process of installing, it will uninstall the old version of ASC 3.0.1 and Smart RAM.


Run Smart RAM within ASC3 with the option "Run at Windows Startup" checked, and see if you get the error again in next boot.



Link to comment
Share on other sites

one error fixed...but another problem??


Thanks for your help Enoskype.

I followed the instruction in the post you noted above...uninstalled AWC 3 and then ran a registry cleaner and deleted the AWC folder. Then I downloaded and installed AWC 3.1.1 and got the same error.


By the way, I use a Windows startup manager program. This is important..because it's how I fixed the runtime error....


My startup manager program had been executing SmartRam.exe with a "/m" setting to minimize the program window when it started. So when I changed over and started using Sup_SmartRam.exe I used the same switch. It looks like this switch no longer works. When I removed it and just set the startup manager run Sup_SmartRam.exe in a minimized mode that worked. No more error message!!!


However, I tried to change my Startup manager to run Sup_ISD.exe (SmartDefrag) instead of SmartDefrag.exe and I can NOT get Sup_ISD.exe to start minimized no matter how I try - with a "/m" switch...with a "/startup" switch or with no switches and in minimized mode. Any suggestions??


Thank you again.


I love AWC. It just keeps getting better and better!


One of my friends recently purchased the PRO version due to my recommendation. But she had to go through a LOT of extra work (including submitting her passport photo page and proof of address!!!) to complete the purchase. This seems like a LOT of UNnecessary trouble for a US$20 purchase. Maybe you could talk to your vendor about "customer service"...because she almost decided NOT to buy AWC PRO because of all of the hassle!!!

Link to comment
Share on other sites

Hi Kailasa108,


Good to hear that your SmartRAM problem is solved. Do you still have SmartRAM.exe file somewhere in your PC for your startup manager to use it?


Interestingly, I have "Sup_SmartRam.exe" with "/m" switch in the Registry, and it works.


("C:\Program Files\IObit\Advanced SystemCare 3\Sup_SmartRAM.exe" /m)


Sup_ISD.exe is not a program itself, it is a command to start IObit SmartDefrag.exe, so, you should have:


("C:\Program Files\IObit\IObit SmartDefrag\IObit SmartDefrag.exe" /StartUp)

in the registry to start it on startup.

You can have that through the Smart Defrag 1.03 Options, ticking "Load automatically at windows startup. (Recommended)" checkbox and Applying.

(If you choose this option, I think it is better to uncheck Disk Defragment option under Diagnose System section in ASC 3.)


I hope this helps.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...