Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Advanced SystemCare Pro Review IObit Coupons A Good Utility Program From IObit IObit Driver Booster Pro Review IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs IObit Software Coupons & Promo Code

I corrupted my PC


Psych

Recommended Posts

Well It's all kinda my fault, but I need some help in this. Basically once I tried to boost my PC through Game Booster, I "Customized" it to close all the background applications by pressing "Check All". Instantly after that windows complained about an error that said "Windows has encountered a critical problem and will restart automatically in one minute. Please save your work now." Once that happened I was confused and thought Windows was just going crazy, after one minute passed it, happened, but the thing is, once it got restarted the screen was black. The application shortcuts on the desktop weren't there, nothing was. The taskbar also wasn't there. Only thing I managed to launch is the Task Manager through "CTRL + ALT + DEL" and Game Booster launched by it self which is weird, because it's the only one.. I'm not sure what happened. I tried to restart with Safe Mode, but the same thing happened.

 

 

- Sorry if this is in the wrong place for support about errors like this, but this is both a suggestion and an asking for help thread, that you guys should warn the users before customizing their settings to boost.

 

Appreciate if you guys would help me in anyway.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Psych. It's my first day on the forums so sorry I didn't post this sooner. Hopefully you found an answer somewhere by now. If not try this:

 

The same thing happened to me and I was on the verge of wiping and reinstalling everything. What worked for me was booting into Safe Mode then running MSConfig from the Run . . . box (simply click Start, Run . . ., then type MSCONFIG in the box and hit enter). That should open the System Configuration Console. One of the tabs is called Services. Click that, select Enable All, then Apply, then Okay, then reboot. Hopefully that will fix the problem.

 

Apparently, Game Booster doesn't restart some of the services it stops and they are left in the Disabled state on reboot. This only happens with me if I click the check box in Game Booster called Show Current User's All Processes and then make changes to processes the system needs. If you leave that box alone and just work with the default choices Game Booster offers you should have no problem. That is, assuming you are experiencing the same problem I had.

 

Good Luck,

 

WW

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...