Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Advanced SystemCare Pro Review IObit Coupons A Good Utility Program From IObit IObit Driver Booster Pro Review IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs IObit Software Coupons & Promo Code

Registry Defrag in XP PRO x64 causes system freeze and windows update issue


roncicotte

Recommended Posts

I am running XP PRO x64 and recently ran into an issue where I lost the functionality of the automatic windows update feature. I had recently installed VS 2008 and SQL Server 2008 and thought at first it was related to the installation of the latest windows installer (4.5) or Frameworks 3.5 required for these apps.

 

After working with a Microsoft rep for 3 days (an exercise in futility) I found the following link through my own research:

 

http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.windowsupdate&tid=35e157b4-aa68-44f1-9b11-d4301756777b

 

This issue describe the behaviour perfectly but did not provide a solution. After more research I found that re-installing IE 7 using the Tools | Internet Options | Advanced | Reset option resolved the issue.

 

I thought life was good until I used AWC 3.2 to clean up my machine after all the changes that had been made. Everything was working fine until I used the registry defrag option. Using this caused the original issue to return.

 

First of all when I used it the program appeared to hang after the analysis phase. After several minutes I tried to close it but the keyboard and mouse appeared to be frozen. Not wanting to interfere with a potential registry change in progresss I let the program sit for more than 15 minutes. When I came back to the computer the dialog was closed but the system was still frozen. I shut the machine down and restarted (holding my breath). The machine came up just fine but testing the windows update showed that the problem had returned.

 

I reset the IE 7 again, verified that windows update worked and restarted the computer.

 

I ran AWC 3.2 (all functions Mainenance and Diagnostics).

 

Checked Windows Update - All is good.

 

Restarted and made sure that all programs were closed (I thought perhaps my Avast anti-virus could have been running the first time). I used the AWC startup manager to make sure nothing started in background in startup

 

Ran Registry Defrag option. Again the system appeared to hang after the Analysis phase reached about 88 to 90%. I let the system sit for more than 15 minutes. The analysis splash screen finally closed but the dialog was still on the page describing the analysis with the Next button highlighted. After selecting next again the Analysis started but quickly closed with the dialog moving to the Finish page stating that the registry did not need to be defragged.

 

I clicked the Finish button and the dialog closed but when I went to the Start button the system froze after displaying the Start popup menu. I waited 15 minutes and the system was still frozen.

 

I powered off the machine and restarted. Checked the Windows Update and the problem had returned. I then reset IE7 and verified that Windows Update works.

 

I have checked AWC and all maintenance and diagnostic functions work and Windows Update continues to work fine.

 

I wanted to post this in case others should run into this issue.

 

Thanks,

 

-ron

 

 

Link to comment
Share on other sites

  • 1 year later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...