Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Advanced SystemCare Pro Review IObit Coupons A Good Utility Program From IObit IObit Driver Booster Pro Review IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs IObit Software Coupons & Promo Code

Something's really wrong here.


Recommended Posts

OK,so I have been having this problem long ago,but I realised it is bigger than expected. So here's what it is: When I want to boost a game,on most of them comes up a message which says: "xxxx.exe has encountered a serious problem and needs to close." But,after I try to play the same games WITHOUT Game Booster, the same message comes up. This is solved by restarting the PC. Even if I successfully boost a game, then ALL of the other games which normally can't be boosted (and haven't been boosted at all) show up the same message. ??!!!???

 

I have also attached a diagnostics report. I have Razer Game Booster patched to the latest version up to this day (10 June 2013, 3.6.0.283). Thanks for any help you may provide me.

Link to comment
Share on other sites

Hi merenidi,

 

Thanks for your feedfacks.:-D

 

To look into the issue, please send us the following details:

 

1) The names of the games that you got the error message when you launch with RGB. ( It can help us do a text).

 

2)Please send us the screenshots to show the error message.

 

Guide for taking screenshot.

 

http://graphicssoft.about.com/cs/general/ht/winscreenshot.htm

 

Thank you for supporting IObit!

Link to comment
Share on other sites

1.OK,so the games which are boosted and aren't working are: Medieval II Total War, Company of Heroes and Call of Duty 4:Modern Warfare.

 

2.Screenshots are posted. (The exact same things happen on all of the 3 games, so I thought that it's OK if I post the screenshots from 1 of them.)

1st screenshot: Pressing the "Launch" button.

2nd screenshot: Loading icon (and then the cinematics part)

3rd screnshot: Error right when the cinematics have ended and the game is starting.

4th screenshot: Technical details about the error.

 

OS: Windows XP Service Pack 3, if this helps.

Link to comment
Share on other sites

Hi merenidi,

 

Thanks for your fast reply.

 

Happy to tell you that we will have an update for Razer Game Booster recently. The issue you met will be solved in the new version. Please just update your RGB when the new version release to solve the issue.

 

Sorry for any inconvenience in these days.

 

Welcome to post your suggestions about our products and service. Cheers.;-)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...