Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Advanced SystemCare Pro Review IObit Coupons A Good Utility Program From IObit IObit Driver Booster Pro Review IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs

verbatim


paprika

Recommended Posts

Hello.

I am unable to open my verbatim external disk on my new laptop windows 8.

in addition I encode with bitlocker.when I click on, I have not the small rectangle where i put the password, it says (F: \ Application not found)

My verbatim 320GB model # 53014

this is the link:

thank you for your support.

Link to comment
Share on other sites

Did you try the solutions on the link in your post, and if so what result did you get when you tried them.

Did you try connecting your external HD to another PC to see if it will open. This will confirm whether the problem is with the HD itself or your pc.

Link to comment
Share on other sites

Hi Scannan,

thank you for your reply.

well, i didn't got any solution from YouTube or other forum and i tried it with another pc,bu the same result.

it was working perfectly no any problem,since i formatted my laptop i think i have lost the bit-locker.

anyway thank Scannan.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...