Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Advanced SystemCare Pro Review IObit Coupons A Good Utility Program From IObit IObit Driver Booster Pro Review IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs IObit Software Coupons & Promo Code

Restore


Daniel S
 Share

Recommended Posts

  • 10 months later...
6 minutes ago, Gabriel Pegasus said:

I know Daniel's original problem may be solved by now, but I'd like to know how.
Because it doesn't make sense to me as I have almost the same issue and I can't see how a removal tool could recover deleted or missing system restore points.

Did you read the Manual??

Link to comment
Share on other sites

5 minutes ago, Scannan said:

Well , if you prefer to guess...rather than read the Manual, which shows how to use the Restore points......

that is entirely your choice.

Sorry, I deleted part of the previous comment I made.

18 minutes ago, Gabriel Pegasus said:

Not entirely, as I don't think what you pointed out seen that can recover files (I guess it uninstall instead)
But one thing catches my attention. Is it possible to recover the files listed in the Uninstall History?

But anyway, I think I know what you mean by restore points. The problem is that I can't find any restore points and I can't create new ones either, and even if I do, it might be deleted on my system for some reason.

Link to comment
Share on other sites

The Uninstall History is simply a list of the files which were uninstalled...so if you did not make a restore point before uninstalling them

then they cannot be recovered.

That said, if there are important/critical files you are trying to recover,...using the History list, you could try the Undelete tool in Iobit Advanced Systemcare, or some other program designed to recover deleted files, such as MiniTool Data Recovery...etc.

With regard to why you have no restore points or cannot create any....did you turn on System Restore in windows.

Did you check that the System Restore service is on.

Link to comment
Share on other sites

Yes, I have already tried everything possible for now.

Multiple recovery tools, like the one you suggested now and in other posts years ago (especially Mini-Tool).

I once recovered these files using the System Restore Point created by the Uninstaller (before removing the program related to them) a few weeks earlier.

But now, no way I can find a solution to recover System Restore Point.

System protection was always on.
I also tried running commands to check for system errors (/chkdsk and sfc).
Change the size of the max. Shadow storage volume.
Recover and restore the Restore Points (using recovery tools) manually.
Even boot Linux to try to repair the disk or use the free recovery tools for this OS.

Nothing seems to work so far, as the error 0×8004231F (saying something like “Insufficient space”) prevents me from creating another restore point.
Even if the allocated size should have been higher than the recommended 20 GB or 20% (something like that) since I changed it at the beginning.

Link to comment
Share on other sites

OK....just to clarify that we are on the same page ....your issue is no longer a Iobit Uninstaller issue, but solely an issue

with system restore. Is this correct.?? and if so,,please explain why you are trying to undelete System Restore points.

As for not being able to create a new Restore Point...Did you try turning off  system protection and then turn it back on. I have seen this fix such issues.

Did you check If your computer's system restore point services are running?

Press Win + R, type services.msc, and press Enter.

Locate Microsoft Software Shadow Copy Provider Service and double-click on it.

In the next window, select Automatic from the Startup type drop-down menu.

From here, click Start under the Service status options. Press Apply and then press OK to save these changes.

 

Link to comment
Share on other sites

Yeah, it has been turning out to be more than a simple issue to only that Uninstaller erasing files without user consent.
It has expanded to the extent that has been unable to recover files (or registry entries) using System Restore Point.

In fact, the problem with System Restore may be more complex than it seems.
But to resume, I tried (and maybe still trying) to recover the missing System Restore Points. Because all of them, one by one, are disappearing from the System, maybe after every reboot or until it has only one.

By searching for a solution and seeing what you adverted here:
“https://forums.iobit.com/topic/15681-deletedmissing-restore-points-in-windows-10/”
I tried to create another Restore Point to see if the System could detect the others.
But unfortunately, none of the solutions I tried related to System Restore repair worked for me.

If I try – turning off System Protection and then turning it back on – it will delete all the Restore Points I am trying to recover. 
And even trying running or setting the services to 'Automatic' doesn't avoid the error (0×8004231F) I got every time.
Should I ask at Microsoft Windows Forum?

Link to comment
Share on other sites

I am trying very hard to assist you, but in order to do so I need to be able to understand your exact issue(s), but you are very confusing in your posts in this regard.

What do you mean by...." that Uninstaller erasing files without user consent"...... Uninstaller, just does not have the ability to do this.

Do you have some other program....such as Iobit Advanced Systemcare...which may be set to automatically erase certain files/folders when you shut down.

What do you mean by...."has been unable to recover files (or registry entries) using System Restore Point"......You say you have no restore points, and now you say this.

Again another confusing statement..."But to resume, I tried (and maybe still trying) to recover the missing System Restore Points. Because all of them, one by one, are disappearing from the System,"..... If you cannot create Restore points, as you have said previously.....then how can they be still disappearing fro the system??

You say....If I try – turning off System Protection and then turning it back on – it will delete all the Restore Points I am trying to recover. 

Yes it will....but you said you have no restore points and could not create any.

I suggest. that you download Iobit Advanced Systemcare (from Majorgeeks site) and use it to create a restore point. Also, it may be able to see any existing restore points whic you have (which I find confusing to even say, because you say that you do and don't have restore points.

As for Microsoft forum, it should be a last resort as they are not very helpful.

You would do just as well looking here...https://www.google.com/search?client=firefox-b-e&q=windows+system+restore+not+working

https://www.google.com/search?client=firefox-b-e&q=error+0×8004231F

 

 

 

Link to comment
Share on other sites

The problem as a whole is extensive and very complicated. I will try to summarize it in only one message:

I help some friends with graphic designs for their blog storybooks. So, after returning from a camping trip and booting up my Windows 11 PC (encrypted with BitLocker), I was ready to get back to my projects.

Issue #1

Shortly after I returned, on July 25, I noticed that something had removed the files in the folder (Discord) with all my projects.
While trying to find out why it happened, I realized that IObit Uninstaller removed them earlier on July 10, after I uninstalled Discord.
Uninstaller using its Delete Leftovers feature deleted not only Discord's registry entries, but also all files in a folder or with the name of this program.


Tried Fix #1.1
The first solution I tried was to use System Restore to recover the entries back to the state before the Uninstaller removed the program.
But unfortunately, the only Restore Points available at the time were from after my return from camping – Including one I did manually to see if System Protection was working.


Tried Fix #1.2
So at the time, I supposed I could recover the files with Recovery Tools like MiniTool, Recuva, and EaseUS. Aside from the limitations of using Free/Trial versions of this software, I could not find the files.
So I tried to find the Restore Point of the early date that I'm sure Uninstaller (or Driver Booster) created. Although I might have found the supposed target files in C:\System Volume Information, the System Restore did not show any other Restore Points other than the existent ones at the time.


Issue #2
After a few days of searching for a solution on my other machine, trying to fix the issue by booting my PC in Safe Mode or even with Linux, I met another problem. I realized that some Restore Points, created after the erasure of the files, began to disappear until only one remained.

Tried Fix #2
After that, I tried creating other Restore Point on Windows, Uninstaller, or Driver Booster, to see if it showed the older ones instead of just the most recent (Manually created on July 27). But to my disappointment, I got the error mentioned before, which prevents me from doing any other more Restore Point. Also, I tried to increase the VSS size again, but it seems all the storage reserved for it is full of data.

 

Finally, I have to point out that:

  1. Maybe the missing Restore Points are corrupted. But they did not show up in Safe Mode, like they don't in Normal Mode.
  2. List the Restore Points on Cmd with the VSS command does not show any other Restore Points. So, no way of erasing them to make space for new ones.
  3. And at the end of all this mess, the Windows Defender service stopped working. Real-Time Protection is off and can't start. Protection Updates gives an error (0×800106ba) and can't scan anything.
Link to comment
Share on other sites

Thank you for the concise reply. Everything is clear now.

First...your last point...error 0×800106ba.....this is usually caused if you have another active anti-virus program running. Windows Defender is designed

to automatically disable it's realtime protection if it detects the other program. This is to avoid possible conflicts.

See here....https://www.google.com/search?client=firefox-b-e&q=0×800106ba

https://ugetfix.com/ask/how-to-fix-windows-defender-error-code-0x800106ba-on-windows-10/

 

Now for your main issue(s)....

Uninstaller, just did as it was asked to do, by you. I hope that you have now realised that it is important to understand how a tool like Uninstaller works before you use it

and that you are familiar with the settings and functions.

 

Sadly, System Restore cannot recover deleted personal files, as it does not save them when creating a restore point.

See here...https://www.google.com/search?client=firefox-b-e&q=does+windows+system+restore+recover+deleted+files

https://www.anyrecover.com/deleted-files-recovery-data/will-system-restore-recover-deleted-files/

So, unfortunately, your only hope is (was) to use the aforementioned recovery tools to find the deleted files, but not by trying to recover deleted Restore points,

but to try to find the actual deleted files in.... the files in the folder (Discord)....

Unfortunately, this may not now be possible, as so much time has passed since they were deleted, and you have been using your machine a lot, and everytime you write new data to your machine there is a danger it will overwrite the deleted files, and then they are gone forever....but it is worth a shot.

As for creating new restore points and the the error (0×8004231F) .......I suggest you go through the links I gave you previously to try to resolve this issue.

Also. did you try using Iobit Advanced Systemcare as I previously recommended.

 

 

Link to comment
Share on other sites

Thanks for trying to help me as much as you can.
I was able to fix the error 0×800106ba just by installing Malwarebytes, as someone has pointed out on another website, to a guy with the same situation (at least with files and registry entries related to Windows Defender).

For the main issue, I'm so sad about knowing, perhaps by accident, that it was really me asking Uninstaller to delete the Discord Files, including the ones within my Personal Files -- and that maybe I can't recover them by normal means.

And yes, I know that system restore could not undelete files removed by normal means. But I hoped that, as Uninstaller deleted the program with its registry entries, I could be able to recover the files altogether with them (As it seems it worked last time in the same situation). So my idea was to recover the state my PC was in before the removal, even if it meant trying the impossible or even trying recovering a lost Restore Point.

Finally, ASC did not help in anything related to System Restore. It shows the same (newer) restore point as DB, Uninstaller, and Windows.

Regarding the Recovery Tools in general, I might not be searching in the right way, path or file. Maybe the data is overwritten, though I can see files way older than the target ones. Also, Recuva can't show the files readily, either.

They might be corrupted at this point, even if they are still on my PC. And with limitations of the Free version of each software, the job became hard to beat, either I can't locate the correct file, can't preview or recover, to do so, or even it's too large or too damaged.

As you can see, my options are very scarce, or I may not be searching the right way. It might be dumb, but maybe it would be helpful to know where Uninstaller sends the files after being deleted and before they get overwritten. So if you can try to help me further, I would appreciate it.
But if you tell me there is no solution and the files are gone forever, I'll be sad but free to move on by working on the next project or rebuilding this one from scratch.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...