Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

Advanced System care freeze during "registry fix"

Recommended Posts

I was having the same problem...the new 3.4.1 version downloaded just fine but would lock up during the Registy Scan portion of the program. I did exactally as suggested:Downloaded the 3.4.1 AGAIN and went to Options > Registry fix > Shortcuts...and unchecked Shortcuts...it no longer locks up and works fine...thanks for the help...I tried contacting Iobit directly but they had no idea what I was talking about..suggested I send them a screenshot for eval..Now how in the world would I do that if the entire compter locks up druing the scan...thanks again..

Link to comment
Share on other sites

Hi vv0350,


Use the Shortcut Fixer utility under Tuneup tab after clicking the Utilities on the main GUI of ASC 3.41. Delete the shortcuts that doesn't have a valid link. Couple of checks of the shortcuts will reveal the validity of the broken shortcuts.

Although shortcut fixer may stall, eventually it will continue to finish.

After that, see if the Registry Fix stalls anymore again.


If you have one, please do not forget to disable System Guard Protection temporarily in your security software before scanning.



Link to comment
Share on other sites

NetHood is the key




I encountered the same problem Antonio and vv0350 had had, on my parents' computer but not on mine, and Google search gave me this thread.


First I tried Magic[Hunter]'s method and it worked! Thanks but... I want shortcuts to be fixed, not skipped. Then I tried Shortcut Fixer recommended by enoskype, yet it freezed too! :x Fortunately, there were two clues telling me what the problem was:


1. While freezing, the CPU usage dropped from high level (common when scanning Windows registry) to just ~10%, which means there's probably something the computer tried to access but didn't require high level of CPU power.

2. The longer path display on Shortcut Fixer showed the program was frozen at C:\Documents and Settings\[insert your username here]\NetHood, a hidden folder (you have to un-hide it via "Folder Options...").


I opened that folder and found several shared folder shortcuts, including one from my old laptop back in the days when I shared family network with D-Links DI-604 router, plus a few from some weird websites. :shock: Apparently the ASC and Shortcut Fixer tried to communicate those remote computers in order to check whether those shortcuts were still valid; there was no such shortcut in the NetHood folder on my computer. Go to "View" tab under "Folder Options..." and disable "Automatically search for network folders and printers," then delete all shortcuts in C:\Documents and Settings\[username]\NetHood folder, and neither Registry Fix nor Shortcut Fixer would freeze again. :-D


Hope it helps.

Link to comment
Share on other sites

Di-604 d-link is old.


The router is old and suggests links to d-link for alot! So old it reckons to the early days of support when machines didn't have much storage capacity or RAM. The possible"wierd sites" are/were configuration links that no longer exist because this device is no longer supported?? As Enoskype suggests, the software may be examining links and will take some time to finish??


Out of my element here completely... but wanted to put in two cents worth, even if its only a penny.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...