Announcement

Collapse
No announcement yet.

Defrag sitting at 36% - Disk activity at 1-2% - CPU activity at 8%

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Defrag sitting at 36% - Disk activity at 1-2% - CPU activity at 8%

    Smart Defrag won't defrag my drive, it just seems to be looking at each file slowly one at a time. Millions of files.. slowly.. one at a time. :/

    Whenever I have a large drive that can't be 'defragmented and prioritised' in one session I stop the process and close the program at the end of the day until I can continue on another day, I have done this many times over the years with many drives and every time Smart Defrag does the same thing - it spends 10 mins verifying the previous day's work and then it continues working from where it left off. Most of that 10 mins is Smart Defrag flying through the drive at what seems like 1,000 files per second.

    It doesn't do that any more though. I have a drive with 5TB of data on it that I am trying to defragment and prioritise, and on the first day it was fine, I got about a third of the drive defragmented in 4 hours before I had to shut down but since then I can't get any more of the drive to defragment - Smart Defrag just quickly gets to 36% and then sits there for the entire session doing nothing, it's not frozen because the progress bar still shows filenames that are being looked at but instead of flying through those filenames at 1,000 every second it's as though it's just reading out their names to show me it's working.

    Four hours today, four hours yesterday and four hours the day before with absolutely no progress at all.

    Is it maybe something to do with a drive setting or one of the options in Smart Defrag?

  • #2
    You say you have 5TB of data but you don't say what the total size of the drive is.
    To err is Human. To really mess things up you need a PC.

    Comment


    • #3
      It's an 8TB drive.

      Comment


      • #4
        That is a huge drive. I suggest that you disable Smart Defrag and run the built in Windows defragment, just to see if the same problem occurs.
        To err is Human. To really mess things up you need a PC.

        Comment


        • #5
          Other defragment programs work fine, as does Smart Defrag, just not when I run the 'defragment and prioritise' mode. When I use that mode it just seems to do nothing while still reporting beneath the progress bar that it is processing files but it can spend four hours inside a single folder that would normally not even take 20 mins to copy in it's entirety.

          Comment


          • #6
            That is why I asked you to disable SM and use the built in windows defragment. It also optimises the drive.
            It will tell us if there is an issue with the prioritising.
            To err is Human. To really mess things up you need a PC.

            Comment


            • #7
              Hi there,

              To look into the issue, please download the tool from:http://testdemo.iobit.com/SDInfoHelper.exe

              Then double click to run this tool and click “Save report to Desktop”. You will get a zipped file IObit_Debug_Info.zip on your desktop. Please send it to us so that we can get the detailed information to look into.

              If the mail can't be delivered because of IObit_Debug_Info.zip, please upload it to http://www.wikisend.com/ and then send the upload link to us.

              Looking forward to hearing from you.
              IObit Support Team --
              If you're happy with our products, please tell your friends, families and colleagues about IObit and IObit products! We'd be very grateful!

              Comment


              • #8
                Scannan: I ran the Windows 10 built-in defrag tool and let it optimise the drive, it completed in around 6 hours and did I believe 4 passes? before finishing with no errors or obstructions.

                Cicely: I ran the SDInfo tool and have attached the IOBit_Debug_Info.zip.

                I can say that the issue is not isolated to my 8TB games drive as today I ran a 'defragment and optimise' pass on my 4TB Windows drive and again it did the same, it got to 39% and then it seemed to just stall - no disk activity, no CPU activity, but the path below the progress bar still showed that files were being worked on. I have uploaded a video alongside the SDInfo.zip to illustrate what I mean.

                I have placed both files in a OneDrive folder.

                https://1drv.ms/u/s!ApWTaWnsmAkHgr5Q...PiUBw?e=b6lCr2

                Comment


                • #9
                  DeLorean
                  Thank you for the reply.
                  So now we know the issue is with SD.
                  I suggest that you run SD defrag only (without Optimise/Prioritise) so we can see if it is the defragmenting or Prioritising which is causing the issue.
                  Also, ensure that Windows Defrag is disabled, and do not run it again while you are dealing with this issue. The Windows Defrag and Smart Defrag, completely
                  undo each others work, and can cause issues.
                  To err is Human. To really mess things up you need a PC.

                  Comment


                  • #10
                    I have run fast defrags many times, and have also ran 'free space defrag' which consolidated everything to the beginning of the drives in the same way the prioritise would (but obviously without prioritising) so the defrag engine is happy to move things around, just not prioritising them. I'm about to run a 'defrag & optimise' as by my reckoning that is the second most "full" defrag after defrag & prioritise.

                    I also tend to have the built-in defrag tool disabled at all times anyway as I got into the habit over the years of using SD to do do a fast defrag before i shut down and a long defrag every few weeks.

                    Comment

                    Working...
                    X