Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer

Automatic Defrag Checkbox [FIXED]


Zatronium

Recommended Posts

So, a while back I reformatted my Hard Drive and installed a SSD which contains my OS and a HDD with all my other files. Then I hardlinked the Program Files and Users folders to the C drive so that these folders appear to be on the C drive (it makes installing and running programs more convenient).

 

The problem I have, is that Smart Defrag continuously unchecks the Auto Defrag box for the HDD (which does have its own drive letter). I need the Auto Defrag option, because I'm constantly moving, creating, and deleting huge (1gb+) files, and it gets fragmented almost daily at times. Is this happening because of my hardlinks, or is something else going on? I did not have this problem when I was using the HDD alone, instead of in tandem with the SSD.

 

P.S. Why did the forum continually say "Sorry, please post in right way." I don't understand what that means, or why I kept getting it until I switched to Internet Explorer.

Link to comment
Share on other sites

  • Replies 57
  • Created
  • Last Reply

HI Zatronium, Welcome to Iobit forum!

 

Some browsers appear to work better here than others and it seems to vary.

 

I don't have a solid state drive, but from the information I've read here and elsewhere, you shouldn't defrag them anyway (there is some kind of risk involved). Perhaps another forum member can enlighten us as to why.

 

Since there are no moving parts, it makes sense that defragging them wouldn't improve their performance.

 

Sincerely,

-Mel

Live long and prosper!

Link to comment
Share on other sites

Misunderstood your post and didn't answer!

 

So you are not defragging your SSD. But because your OS is on the SSD and you are not defragging it (auto defrag is off), Smart defrag is turning the auto defrag off on the HDD (probably because the OS is hardlinked to the SSD).

 

Please verify that you are using Smart Defrag Ver. 2.2 . If you are not you can update to 2.2 here -> http://www.freenew.net/windows/smart-defrag-2-2/68806.htm

 

If you are already using ver. 2.2 or you get it and have the same problem, post back and I will point your thread out to a staff member at Iobit so their engineers can look at this.

 

Sincerely,

-Mel

Live long and prosper!

Link to comment
Share on other sites

  • 1 month later...

Sorry for not replying sooner, I forgot I wrote this thread.

 

(probably because the OS is hardlinked to the SSD)

That's what I figured; if a program isn't cognizant of Hardlinks, it might assume the two drives are simply different partitions of the same physical drive.

 

I do indeed have version 2.2, so this is an issue in the current version. It's a great piece of software, I only wish it worked with my computer setup! Thanks for your correspondence, I guess I'll just have to defrag manually for now.

Link to comment
Share on other sites

Hi Zatronium,

 

Sorry for the delay of reply, we have forwarded this issue to our engineers, please kindly help us look into it.:-)

 

1) You said," Smart Defrag continuously unchecks the Auto Defrag box for the HDD (which does have its own drive letter)." Please take a screen shot of the trouble and send it to us.

 

Guide for Taking Screenshots:

 

http://graphicssoft.about.com/cs/general/ht/winscreenshot.htm

 

2) Please download the DriveCheck.rar and extract it to get DriveCheck.exe, double click the icon and click on the button "Method 1", then send us the DriveCheck_Method1.txt where you put the DriveCheck.exe.:wink:

DriveCheck.rar

Link to comment
Share on other sites

Welcome to the Iobit forum am_dew!

 

I am glad that you have posted your log! I will send Cicely a PM concerning this (asking her to view this thread again) as this can only be resolved within Iobit programming.

 

Thanks!

 

Sincerely,

-Mel

Live long and prosper!

Link to comment
Share on other sites

Hi am_dew,

 

Thanks for your feedback, we are sorry we don't get the meaning very clearly, :-|please kindly help us.

 

Please help us confirm that whether you can't tick the checkbox on the left hand or you can't turn on the Automatic Defrag. (Please see the attached picture)

 

If possible, please take a screen shot of the trouble and send it to us, it will greatly help us look into this issue.

 

Thanks in advance!;-)

Link to comment
Share on other sites

Hi am_dew,

 

Thanks for your feedback, we are sorry we don't get the meaning very clearly, :-|please kindly help us.

 

Please help us confirm that whether you can't tick the checkbox on the left hand or you can't turn on the Automatic Defrag. (Please see the attached picture)

 

If possible, please take a screen shot of the trouble and send it to us, it will greatly help us look into this issue.

 

Thanks in advance!;-)

 

I can do both of these things HOWEVER as I said in my original post, the Automatic Defrag option does not stay on "Yes" after a system reboot. There is not a lot that will show in a screen shot other than the Automatic Defrag option being set to "No".

 

It's really a straight forward problem -- the Automatic Defrag option changes to "No" after a reboot despite setting it to "Yes" before the reboot.

 

Thank you.

Link to comment
Share on other sites

Hi am dew!

 

Perhaps the issue has been resolved in the new version of Smart Defrag (ver. 2.3)! I am curious if you have already upgraded to it and if you had received a "pop up" window in ver. 2.2 offering the new version?

 

If you have not already upgraded, you can find it on this thread: http://forums.iobit.com/showthread.php?t=12269

 

I suggest a clean install using these guidelines: http://forums.iobit.com/showthread.php?p=39220#post39220 and http://forums.iobit.com/showpost.php?p=42228&postcount=10

 

Sincerely,

-Mel

Live long and prosper!

Link to comment
Share on other sites

Perhaps the issue has been resolved in the new version of Smart Defrag (ver. 2.3)! I am curious if you have already upgraded to it and if you had received a "pop up" window in ver. 2.2 offering the new version?

 

If you have not already upgraded, you can find it on this thread: http://forums.iobit.com/showthread.php?t=12269

 

I suggest a clean install using these guidelines: http://forums.iobit.com/showthread.php?p=39220#post39220 and http://forums.iobit.com/showpost.php?p=42228&postcount=10

 

Sincerely,

-Mel

Live long and prosper!

 

I have not upgraded to v2.3 and as of about an hour ago, I was not prompted to upgrade. I am at work now but will upgrade this evening and let you know how it goes.

Link to comment
Share on other sites

Do I understand correctly that Smart Defrag 2.3 is not performing automatic defrag after clean install?

 

Cheers.

 

Once again...

 

The Auto Defrag "YES" setting on the main screen reverts to "NO" at some point between closing (exiting) and restarting the program. I don't know how else to explain it...it is simply not saving the "YES" setting.

Link to comment
Share on other sites

am_dev please open Config.ini @

C:\Users\User Name\AppData\Roaming\IObit\Smart Defrag 2

and see what are the values for:

EnableAutoDefrag=

and

AutoDefragVolumes=

after saving the settings and after restarting the program.

 

Cheers.

 

I was one step ahead of you... :-D

 

I checked this file and found the settings as follows:

 

EnableAutoDefrag=1

AutoDefragVolumes=J:\;K:\;L:\;

 

So, it appears that the settings are being saved however the GUI is not reflecting the settings in the INI file.

 

BTW, I am an IT Support Analyst with almost 30 years of IT experience so I think I know what I am doing.

Link to comment
Share on other sites

Hi am_dew

Could you please provide a screenshot of your settings!

Cheers

solbjerg

 

I was one step ahead of you... :-D

 

I checked this file and found the settings as follows:

 

EnableAutoDefrag=1

AutoDefragVolumes=J:\;K:\;L:\;

 

So, it appears that the settings are being saved however the GUI is not reflecting the settings in the INI file.

 

BTW, I am an IT Support Analyst with almost 30 years of IT experience so I think I know what I am doing.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...