Jump to content
IObit Forum
Top Free Driver Updater Tools Best 25 PC Optimization Software Best 22 Antimalware Best 22 Uninstaller Software IObit Coupons & Discount Offers PC Optimizer Mac Boost Advice IObit Coupons A Good Utility Program From IObit IObit Promo Codes IObit Coupon Codes IObit Coupons and Deals FAQs Driver Booster Pro Review

ASC Ultimate Database updates not working with proxy [SOLVED]

Recommended Posts

Hi Cicely, just found your response today..thanks..


Definite improvement (so far).


It is now downloading.. tho' the bit rate is relatively low, varying between about 16-80kbits/s with some breaks from according to one graph, but avg is less than 4.5kbits/s.

Link to comment
Share on other sites

  • Replies 123
  • Created
  • Last Reply

Ok, the log seems to show it's just repeating a failure. Here's part of it.


If that's true, there's some error detection logic missing... seems to be an infinite or very very long loop.. so I've cancelled it. It said it was 'getting update information'.


2012-12-25 17:54:08 357 Callback:0

2012-12-25 17:54:08 377 Update started

2012-12-25 17:54:08 411 Callback:20

2012-12-25 17:54:08 430 F_BDUpdSdkPerformUpdate fin

2012-12-25 17:54:08 456 IsHaveUpdate end

2012-12-25 17:54:08 474 Get DB Error :IsHave

2012-12-25 17:54:08 794 IsHave:Test 1 Download Succeed

2012-12-25 17:54:08 969 IsHave:Test 2 Download Succeed

2012-12-25 17:54:09 244 IsHave:Test 3 :

2012-12-25 17:54:09 264 IsHave:Test 3 Download failed Message HTTP/1.1 404 Not Found

2012-12-25 17:54:09 283 IsHave:Test 3 Download failed ResNum 404

2012-12-25 17:54:09 510 Get update info succeed 1

2012-12-25 17:54:09 566 Get update info succeed 2

2012-12-25 17:54:09 606 IsHaveUpdate start

2012-12-25 17:54:09 625 GetProcAddress

2012-12-25 17:54:09 644 Callback:0

2012-12-25 17:54:09 662 Update started

2012-12-25 17:54:09 697 Callback:20

2012-12-25 17:54:09 715 F_BDUpdSdkPerformUpdate fin

2012-12-25 17:54:09 734 IsHaveUpdate end

2012-12-25 17:54:09 753 Get DB Error :IsHave

2012-12-25 17:54:10 071 IsHave:Test 1 Download Succeed

2012-12-25 17:54:10 249 IsHave:Test 2 Download Succeed

2012-12-25 17:54:10 577 IsHave:Test 3 :

2012-12-25 17:54:10 600 IsHave:Test 3 Download failed Message HTTP/1.1 404 Not Found

2012-12-25 17:54:10 627 IsHave:Test 3 Download failed ResNum 404

2012-12-25 17:54:10 953 Get update info succeed 1

2012-12-25 17:54:11 007 Get update info succeed 2

2012-12-25 17:54:11 044 IsHaveUpdate start

2012-12-25 17:54:11 063 GetProcAddress

2012-12-25 17:54:11 082 Callback:0

2012-12-25 17:54:11 101 Update started

2012-12-25 17:54:11 136 Callback:20

2012-12-25 17:54:11 155 F_BDUpdSdkPerformUpdate fin

2012-12-25 17:54:11 175 IsHaveUpdate end

2012-12-25 17:54:11 195 Get DB Error :IsHave

2012-12-25 17:54:11 567 IsHave:Test 1 Download Succeed

2012-12-25 17:54:11 741 IsHave:Test 2 Download Succeed

2012-12-25 17:54:12 069 IsHave:Test 3 :

2012-12-25 17:54:12 089 IsHave:Test 3 Download failed Message HTTP/1.1 404 Not Found

2012-12-25 17:54:12 108 IsHave:Test 3 Download failed ResNum 404

2012-12-25 17:54:12 587 Get update info succeed 1

2012-12-25 17:54:12 675 Get update info succeed 2

2012-12-25 17:54:12 713 IsHaveUpdate start

2012-12-25 17:54:12 735 GetProcAddress

2012-12-25 17:54:12 755 Callback:0

2012-12-25 17:54:12 782 Update started

2012-12-25 17:54:12 823 Callback:20

2012-12-25 17:54:12 869 F_BDUpdSdkPerformUpdate fin

2012-12-25 17:54:12 896 IsHaveUpdate end

2012-12-25 17:54:12 920 Get DB Error :IsHave

Link to comment
Share on other sites

Hi dalchina,


Thank you for your kindly reply.


We are wondering whether you have successfully downloaded Autoupdate.exe and put it into the program's installation folder.


If you were failed to download it, we advise you to try it again by using another browser.


Thanks in advance.

Link to comment
Share on other sites


Current Autoupdate.exe

CRC32 = 836452BE

MD5 = 25269D840DED6CCE482829CAB5DE614A


Old Autoupdate.exe


MD5 = F1711B1A4E5AEEA1451349F99F7E1A88


I renamed the old file, and pasted the new one into the folder.

If you compare these using 'properties' you can determine if the file is intact.



Link to comment
Share on other sites

Cicely take provided the solution, you gave the dalchina user, change the file autoupdate.exe, apparently works (after 5 months) the error was in this file


An hour ago that trying to update the database that's already an improvement



Link to comment
Share on other sites

Mm, yes, as I thought until I discovered it wasn't getting anywhere and seemed stuck in a loop.


autoupdate.log shows



2012-12-26 11:07:45 344 IsHave:Test 2 Download Succeed

2012-12-26 11:07:45 632 IsHave:Test 3 :

2012-12-26 11:07:45 657 IsHave:Test 3 Download failed Message HTTP/1.1 404 Not Found

2012-12-26 11:07:45 681 IsHave:Test 3 Download failed ResNum 404

2012-12-26 11:07:46 016 Get update info succeed 1




autoupdate.exe accesses

=> 404 not found from a browser.

Which may be consistent with the '404' in the log.

But the program is downloading some data.. but my guess is it's the same again and again.


Running a 'whois' check on it gives


[Querying whois.arin.net]

[Redirected to whois.ripe.net:43]

[Querying whois.ripe.net]


% This is the RIPE Database query service.

% The objects are in RPSL format.


% The RIPE Database is subject to Terms and Conditions.

% See http://www.ripe.net/db/support/db-terms-conditions.pdf


% Note: this output has been filtered.

% To receive output for a database update, use the "-B" flag.


% Information related to ' -'


inetnum: -


descr: NETBLK-03-EU-93-184-220-0-22

country: EU

admin-c: DS7892-RIPE

tech-c: DS7892-RIPE



source: RIPE # Filtered


person: Derrick Sawyer

address: 2850 Ocean Park Blvd., Suite 200, Santa Monica CA 90405 USA

phone: +18773343236

nic-hdl: DS7892-RIPE

source: RIPE # Filtered


Link to comment
Share on other sites

Since Advanced Systemcare uses both BitDefender antivirus technology and the IObit anti-malware engine, I guess the update is from a source specific to IOBIT. Thus proving you can update Bitdefender itself would not necessarily be the same thing, or prove anything useful.

Link to comment
Share on other sites

Safe Mode (with networking)


Ok, for what it's worth I tried the following:

1. Ran ASC in SM with Networking: update behaviour unchanged

2. As there's no 'Repair' option, I reinstalled in SMode.

3. That (of course) restored the old autoupdate.exe- on update attempt, connection aborted immediately as before.

4. Replaced autoupdate.exe with new version

- update behaviour the same.


This eliminates some possible conflict issues, and obviously, the firewall.


Outside possibilities are sthg to do with a driver or a service.


Personally, given the '404' I suspect sthg to do with internet access.

Link to comment
Share on other sites

More technical:

I've now 'profiled' autoupdate.exe with Dependency Walker (depends.exe)





With that installed, you can open the log file in the attached zip.


That gives a very detailed account of its execution.. and eventually it lists some files- dlls etc- not found.


Dependency Walker does say that

Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

When autoupdate.exe is opened in Dependency Walker initially.


Comparing this with a PC where the update works may show sthg useful.


Hope that helps.

Link to comment
Share on other sites



Your User CP system information does not state that you have ASC installed. You should include this information so we know which version you have installed.


Please confirm whether your ASC is running correctly. Are you having difficulties connected to the English language file, or are you just curious about Dependancy Walkers result.

Is English your selected language for ASC.

Link to comment
Share on other sites

With respect to msvcr80.dll:

If this IS required..

"In future, if you think you need a copy of this file, you should contact the publisher of the application that says it needs it. msvcr80 is not distributed centrally by Microsoft, but instead 'comes with' the applications you use."


Link to comment
Share on other sites

enoskype: Thanks, actually that's not possible, sorry. %programfiles% is set to D:\, something I've done thru a few generations of Windows now. Why? I've got a LOT of programs installed, and I did once have the vague hope of separating quite a lot of my user data from Windows (which of course is impossible except in simple cases).


It was also so D:\ (full of programs) didn't often need defragging, whereas C:\ did. Not that I do that often. Anyway, both C:\ and D:\ are relatively large.


It's never really caused a problem as such..


Note that Victor2k is experiencing the same symptom.


Victor2k- could you quote your install path please? ;-)

Link to comment
Share on other sites

Scannan: Thanks - er, don't know what CP is, sorry. Equally, was unaware some profile stuff should contain this.. I used a login I've had for a while I think.


Yes, other than the update process never getting anywhere useful, the program runs.


It's v6.07.24, ASC Ultimate, English, on Win 7 Ultimate English 32 bit, up to date. I installed it in English.


Why Dependency Walker? Well, I'm assuming Victor2k & I might be the exceptions to the 1000s who can update successfully. Since the dev. team don't have access to our PCs, they need some evidence to work from.


So I thought that was worth a shot- it certainly shows some files apparently missing. Should they be present?

Link to comment
Share on other sites



If you look at the top left corner of the page you will see UserCP. If you click on this it will take you to your profile page, where you can update your system information. It helps us to assist you.


I have checked on my system, and I also do not have the files referenced in your screenshot, so I have to assume that they are unnecessary, as my ASC works fine. Maybe an Iobit team member will have more info on them and their function.


I had a look at Dependency Walker, and it seems like a very useful tool. I may download it myself, so thank you for the info.


With regard to your and Vicktor2K's updating problem. I am sorrry but I do not have anything additional to suggest at the moment. It seems all avenues have so far been tried. I think that only Iobit will be able to figure out the problem, so hopefully with the latest feeedback, they may come up with something. I will however continue to search for a solution.

Link to comment
Share on other sites



Couldyou please complete your system information in your UserCP panel. You can find this at the top lefthand corner of the page. This would help us to solve your problem by enabling us to see if there are any common denominators between your system and Dalchina's.

In particular please state your OS, your AV, your version of ASC, your Browser and your Firewall.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...